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Installing Kerio Operator

Product Editions

Software Appliance

Kerio Operator Software Appliance is an all-in-one package of Kerio Operator which also

includes a special operating system.

Designed to be installed on a computer without an operating system, this edition is dis-

tributed as an installation disc. Software Appliance cannot be installed on a computer

with another operating system and it does not allow to install other applications.

VMware Virtual Appliance

A virtual appliance designed for use in VMware products.

VMware Virtual Appliance is a Software Appliance edition pre-installed on a virtual host

for VMware. The virtual appliance is distributed as OVF and VMX.

Kerio Operator Box

Hardware device ready for network connection. There are two types which differ in per-

formance.

Kerio Operator Software Appliance

For Kerio Operator system requirements, refer to the Kerio Operator product pages.

You obtain Kerio Operator as a standard ISO image which you need to burn on a CD. Boot

from this CD and install the Kerio Operator operating system. The Kerio Operator application

is also installed during the process.

How to connect Kerio Operator to network

After booting the system, a console with the IP address for Kerio Operator is displayed.

If you use a DHCP service on your network, Kerio Operator will be assigned an IP address

automatically and will connect to the network. If you do not use or do not wish to use DHCP

for Kerio Operator, you have to set the IP address manually.

The current network configuration is displayed (and can be changed) in the Kerio Operator

console in section Network Configuration. To set a static network address:

1. Select the Assign static IP address option in the console menu.

2. In the network interface on which the PBX should communicate, select the Assign static

IP address option and enter the IP address, subnet mask and IP addresses of gateway

and DNS server.

http://www.kerio.com/operator/technical-specifications
http://www.kerio.com/operator/technical-specifications
http://www.kerio.com/operator/technical-specifications
http://www.kerio.com/operator/technical-specifications
http://www.kerio.com/operator/technical-specifications
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If you know the DNS name of the PBX, you can connect to it and configure it via the web

interface.

Immediately after you connect Kerio Operator to the network, we recommend to read

article concerning the security measures. Meeting security principles for Kerio Operator

operation is extremely important. If the PBX is not protected by a firewall and supporting

security rules, your internal telephone extension can be misused which may result in

unexpected financial costs.

Kerio Operator VMware Appliance

For supported VMware product versions, check

http://www.kerio.com/operator/requirements/

Use an installation package in accordance with the type of your VMware product:

• For products VMware Server, Workstation, Player and Fusion, download the

compressed VMX distribution file (*.zip), unpack it and open the file with extension

.vmx.

• You can import a virtual appliance directly to VMware ESX/ESXi from the URL of the

OVF file — for example:

http://download.kerio.com/dwn/operator/

kerio-operator-appliance-1.2.0-2500-vmware.ovf

VMware ESX/ESXi automatically downloads the OVF configuration file and

a corresponding disk image (.vmdk).

If you import virtual appliance in the OVF format, bear the following specifics in mind:

• In the imported virtual appliance, time synchronization between the host and

the virtual appliance is disabled. However, Kerio Operator features a proprietary

mechanism for synchronization of time with public Internet time servers. Therefore,

it is not necessary to enable synchronization with the host.

• Tasks for shutdown or restart of the virtual machine will be set to default values after

the import. These values can be set to “hard” shutdown or “hard” reset. However,

this may cause a loss of data on the virtual appliance. Kerio Operator VMware

Virtual Appliance supports so called Soft Power Operations which allow to shut down

or restart hosted operating system properly. Therefore, it is recommended to set

shutdown or restart of the hosted operating system as the value.

For more information, see section Network Connection.

http://kb.kerio.com/816
http://kb.kerio.com/816
http://kb.kerio.com/816
http://kb.kerio.com/816
http://kb.kerio.com/819
http://kb.kerio.com/819
http://kb.kerio.com/819
http://kb.kerio.com/819
http://www.kerio.com/operator/technical-specifications
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Kerio Operator Box

For currently supported Kerio Operator Box configurations, refer to the Kerio Operator

product pages.

For detailed information on connecting the device into the network, see the Kerio Operator

Box, Installation Guide.

How to connect box to network

Upon the first start, the appliance has a static IP address set to 10.10.10.1 on ehthernet port

1. There are two ways to change the configuration:

• In the console — use an Ethernet cable to connect to the console. In the console menu,

select the Network Configuration option and change the configuration.

• In the administration interface in section System.

To connect to Kerio Operator, set the following TCP/IP parameters on your computer:

• IP address: 10.10.10.2

• Subnet mask: 255.255.255.0

To shut down the appliance:

1. Connect to Kerio Operator via the console and select the Shutdown command.

2. Kerio Operator series 1000 will shut down.

Kerio Operator series 3000 will stop the server, however, the physical appliance stays

switched on. Wait until you are not able to connect to Kerio Operator via Kerio Operator

administration and turn the appliance off using the pwr button on the appliance.

http://www.kerio.com/operator/technical-specifications
http://www.kerio.com/operator/technical-specifications
http://www.kerio.com/operator/technical-specifications
http://www.kerio.com/operator/technical-specifications
http://www.kerio.com/operator/technical-specifications
http://download.kerio.com/dwn/kerio-operator-installguide-multi.pdf
http://download.kerio.com/dwn/kerio-operator-installguide-multi.pdf
http://download.kerio.com/dwn/kerio-operator-installguide-multi.pdf
http://download.kerio.com/dwn/kerio-operator-installguide-multi.pdf
http://download.kerio.com/dwn/kerio-operator-installguide-multi.pdf
http://kb.kerio.com/816
http://kb.kerio.com/816
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Logging into Kerio Operator

Which Kerio Operator interfaces are available

• administration interface (Kerio Operator Administration)

• user interface (Kerio Operator client)

We recommend to use the supported browsers to connect to the interfaces. For the list of the

browsers, refer to the Kerio Operator product pages.

Web interfaces are currently localized into several languages. Select yours in the top right

corner of the interface. The default language is set according to your browser language

settings.

Kerio Operator Administration

How to login

Before you login the first time, make sure you have:

• DNS name of the server with Kerio Operator.

• Supported browser

To login, enter the DNS name of the computer with Kerio Operator:

kerio.operator.name/admin

Administration runs solely via the HTTPS protocol on port 4021. The address is automatically

redirected to:

https://kerio.operator.name:4021/admin

If the PBX is located behind firewall, HTTPS on port 4021 must be enabled.

If the URL is entered correctly, your browser displays a warning about a SSL certificate. After

the installation, Kerio Operator creates a certificate which is not signed by a trusted certificate

authority — it is a self-signed certificate (for more information, read article about the SSL

certificates). Since you know the certificate can be trusted, you can add the security exception

and continue to a login page.

http://www.kerio.com/operator/technical-specifications
http://www.kerio.com/operator/technical-specifications
http://www.kerio.com/operator/technical-specifications
http://www.kerio.com/operator/technical-specifications
http://www.kerio.com/operator/technical-specifications
http://kb.kerio.com/article/configuring-ssl-certificates.html
http://kb.kerio.com/article/configuring-ssl-certificates.html
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First login

When you connect to the PBX for the first time, a configuration wizard is displayed where you:

1. Set the configuration wizard language.

2. Accept the Kerio Operator license agreement.

3. Set a password for the administration account (be sure to remember the password, you

will need it to login to the PBX).

This admin password is synchronized with password of user root in the

operating system where Kerio Operator is installed (Kerio OS).

4. Set the time zone of Kerio Operator (requires a restart of the PBX).

5. Set the PBX language for communication with you and other users (warnings, auto

attendant scripts, voicemail, etc.).

6. Configure the first extension number. If you use phone provisioning, extensions will be

created automatically beginning with the number you enter here.

After successful configuration, the login page is displayed. Enter the username and password

you created earlier.

Figure 1 Login to administration
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To change the password, use the following steps:

1. Login to Kerio Operator using the HTTPS protocol

(e.g. https://operator.company.com/admin)

2. Open the Configuration → Users section.

3. In the user list, select the administrator account you are logged in with and double-click

on it.

4. Change the password on tab General.

Kerio Operator client

Kerio Operator client overview

With Kerio Operator client, users can access their:

• voicemail,

• phone account configuration (change password, change PIN or call forwarding),

• call history.

You can also dial numbers in Kerio Operator client. You have to be connected to a phone

(softphone on your computer or mobile phone or hardware phone on your desk). Dialing in

Kerio Operator client works on callback basis. This means that when you dial a number, your

phone rigs first. Once you answer your phone, Kerio Operator stars dialing the number and

connects you.

The advantages of dialing via Kerio Operator client are:

• If you want to dial an internal extension, you don’t have to know it by heart — just

type in the name of the user.

• In Kerio Operator client, you can configure the speed dial buttons with names and

numbers and dial with only one click.

How to login to Kerio Operator client

1. Specify URL in the browser in the following format:

http://kerio.operator.name/

2. If the URL is entered correctly, Kerio Operator client login page is displayed.

3. Use credentials of Kerio Operator user.
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Figure 2 Login to Kerio Operator client
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Using Dashboard in Kerio Operator

Dashboard overview

New in Kerio Operator 2.2!

Kerio Operator includes a customizable Dashboard. Dashboard consists of tiles. Each tile

displays a different type of information (graphs, statistics, etc.)

Dashboard is displayed in Kerio Operator after each login.

To display Dashboard later, go to Configuration → Dashboard.
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Licenses and registrations

How to register Kerio Operator in the administration interface

You can register the product from the welcome page of the administration interface which is

displayed after each login.

If Kerio Operator is protected by a firewall, it is necessary to allow outgoing HTTPS

traffic for Kerio Operator at port 443. Unless HTTPS traffic is allowed, Kerio Operator cannot

use the port to connect to the Kerio Technologies registration server.

When installed, the product can be registered as trial or as a full version.

Why to register the trial version

The trial version is intended to allow the customer to become familiar with the product’s

features and configuration. Once you register the trial version, you will be provided free Kerio

Technologies technical support during the entire trial period (up to 30 days).

Figure 1 A Product Registration tile
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The trial version can be registered by clicking on Become a registered trial user on Dashboard

(see figure 1). In the dialog box just opened, set the following parameters:

1. enter security code (CAPTCHA) from the image.

2. enter information about your company and agree with the privacy policy terms.

3. choose how many computers do you have in your company and how you learned of Kerio

Operator.

Now, a special identification code called Trial ID gets generated. This ID is later required for

contacting the technical support. After a successful registration, Trial ID can be found in the

license information in the administration interface.

Once you purchase the product, your Trial ID will become your license number (it will

not change).

Registering full version

If your trial version is registered, the license key (licence.key file) is automatically imported

to your product within 24 hours from your purchase. The Trial ID you entered in your product

upon registration will be activated as a standard license number.

If you haven’t registered your trial version:

1. Open the administration interface.

2. Click Register product with a purchased license number on Dashboard.

3. In the first step of the registration, enter the license number and enter the security code

from the image.

The code is not case-sensitive.

4. Click Next to make Kerio Operator establish a connection to the registration server and

check validity of the number entered.

If the number is invalid, the registration cannot be completed.

5. Type the registration information about the company the product is registered to.

6. Kerio Operator connects to the registration server, checks whether the data inserted is

correct and downloads automatically the license key (digital certificate).

7. Click Finish to close the wizard.
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Manual import the license key

If you need to import a license key manually (for example from a backup), use the following

steps:

1. Prepare the license key.

2. Login to Kerio Operator administration.

3. Click Install license on Dashboard.

4. In the Install License dialog, click Browse.

5. In the Open dialog, find the file .key with the license key and click Open.

6. In the Install License dialog, click OK.

7. Check the result in the License tile on Dashboard.

Kerio Operator installs the licence key.

Registering via a web browser

You purchased a license and your Kerio Operator cannot access the Internet? Follow these

steps to register the product:

1. Go to https://secure.kerio.com/reg/

2. Register using your purchased license number.

3. By registering, you will receive a license key which must be imported to Kerio Operator.

The trial version of Kerio Operator cannot be registered via the website.

https://secure.kerio.com/reg
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Securing Kerio Operator

Issues to address

• Restrict communication on firewall to necessary IP addresses and ports, especially if

the PBX runs in the Internet.

• Restrict communication on the integrated firewall in Kerio Operator.

• Create strong SIP passwords.

• Restrict the number of attempts to enter SIP passwords.

• Using special rules, forbid international outgoing calls to countries you do not

communicate with

• Restrict international outgoing calls to countries where you rarely call

The following sections describe these settings in detail.

How to configure firewall in local network

Kerio Operator is usually protected by firewall (in your local network or in the Internet).

Certain ports need to be opened (or mapped) on firewall.
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Service (default port) Outbound connection Inbound connection

SIP (5060) allow allow for SIP servers of your

provider

IMAP (143) allow if integration with Kerio

Connect is enabled and there is

a firewall between Kerio Connect

and Kerio Operator.

deny

LDAP (389) allow deny

LDAPS (636) allow allow if you use mapping from

Active Directory or Open

Directory and there is a firewall

between the directory service and

Kerio Operator.

HTTP (80) allow deny

HTTPS (443) allow allow if you wish users to be able

to connect to Kerio Operator

client from the Internet.

HTTPS (4021) allow allow if you wish users to be able

to connect to the administration

interface from the Internet.

Table 1 Services to be allowed on the firewall

How to configure firewall integrated in Kerio Operator

Prepare groups of IP addresses which you wish to allow for individual services (create them in

Configuration → Definitions → IP Address Groups).

You can configure the integrated firewall in section Configuration → Network → Firewall.

Web server

If you want to restrict connections to Kerio Operator administration and client, check this

option and select an IP group with addresses from which access will be allowed. Bear in

mind that all the PBX users should be allowed to connect to Kerio Operator client at least

from their own workstation.

SIP

We recommend to restrict the SIP protocol solely to your internal network and external

IP addresses of your SIP provider.
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Phone provisioning

For security reasons, we recommend to restrict automatic phone provisioning solely to

your internal network because TFTP sends configuration data as plain text.

CRM integration

For security reasons, we recommend to restrict communication solely to your internal

network.

SNMP monitoring

For security reasons, we recommend to restrict communication solely to your internal

network and IP adressess where monitoring servers are running.

If the options are unchecked, no restrictions are set.

How to configure protection against password guessing

Login data guessing is one of the most common attacks on a PBX. In Kerio Operator, attackers

try to guess extension numbers and SIP passwords. This type of attack is defined by many

unsuccessful attempts to enter extension number and SIP password during a login. Kerio

Operator security settings enable you to limit the number of attempts of a phone (both

software and hardware) to connect to the PBX. Apply settings as described below:

1. In the administration interface, go to Configuration → Security.

2. Set the limit of unsuccessful attempts (usually 3 to 10 attempts) and set the time period

during which attempts will be counted.

Setting the time period protects real users who have forgotten their password or who have

made mistakes during several logins. When the time limit expires, they can try to login to

the PBX again.

3. Set the time during which Kerio Operator will block the source IP address.

4. You can also enter an email address that will be used for sending warnings about blocked

IP addresses.

How to recognize there has been an attack attempt

In log Security look for the Authentication failed string. If there are many messages of

this kind, somebody is trying to use a dictionary attack.
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What to do in case of an attack

In case of an attack, apply the following instructions as soon as possible:

1. In section Status → Calls and in logs, look for information on which account has been

abused.

2. Change the SIP password of this account.

3. Instruct users about handling their login details and secure behavior on the Internet.

4. The PBX is blocked, so it needs to be unlocked again.
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Creating user accounts

User accounts overview

User accounts in Kerio Operator are used for:

• login users to Kerio Operator client,

• link users with an extension,

• set access rights to the system.

Adding new accounts

You can add either new local accounts or existing accounts from a directory service.

Adding local accounts

If you do not use directory services, create a local user in the Kerio Operator administration.

In section Configuration → Users, click on the Add option.

On the General tab, fill in username and password. The username must not contain spaces,

national and special symbols. Other items are optional.

Adding accounts from directory service

You need basic login credentials to connect directory service to Kerio Operator.

To add users from a directory service, you need to:

• to set mapping from directory service

• activate users

For more information, read Connecting Kerio Operator to directory service.

How to connect Kerio Operator with directory service

Mapping differs according to the directory service used:

• Microsoft Active Directory

• Apple Open Directory

http://kb.kerio.com/article/connecting-kerio-operator-to-directory-service-823.html
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Adjusting the Users table

When you display section Users, you can see the following columns by default:

• Username

• Full Name

• Extensions

• Ringing Rules

However, you can display more columns (see figure 1).

Figure 1 Adjusting columns in the Users table

Additional information

Information about adding, removing or editing users can be found in the Config log.



28

Redirecting Calls

What is call forwarding

Incoming calls can be routed to different internal extensions or external numbers. Calls may

either ring only at the redirected phone or at all phones at a time.

How to configure call forwarding in the administration

Example:

Mr Peter Prank, General Manager at Live And Let Laugh Inc, requires that his calls are

forwarded to:

• his desk phone (internal extension in Kerio Operator),

• to his company cell phone (to be available in case the server is down),

• we disable redirecting to voicemail because his boss hates voicemail.

Configure the redirecting as follows:

1. Thomas Punchline, the company network administrator, goes in the Users section in Kerio

Operator and double-clicks on the IT administrator’s account.

2. In the edit user dialog, he goes to the Ringing Rules tab.

3. He selects the Forward to option and enters the cell phone number in appropriate format.

This means a format which is required by the VoIP service provider. He adds a prefix for

outgoing calls.

4. He disables option Fallback to voicemail.

Users can also use the Kerio Operator client interface to forward their calls. It is

therefore necessary to be careful for them not to overwrite their own settings.

How to configure call forwarding in Kerio Operator client

If users wish to redirect calls to another number, they can do so in their Kerio Operator client.

The settings are described in article Redirecting calls in Kerio Operator client

http://kb.kerio.com/product/kerio-operator/kerio-operator-client-myphone-/redirecting-calls-in-kerio-operator-client-938.html
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Creating extensions

Extension overview

An extension is an internal telephone line. Each user can have assigned one or more extensions

in Kerio Operator.

The total number of extensions is limited to three times the number of licensed users.

Service extensions configured on the PBX services tab are not counted by the license

file.

Adding new extensions

You have three options to add a new extension:

• An extension is created automatically when you connect a provisioned phone to the

network.

• You can create an extension in Configuration → Users — the extension is assigned to

a particular user.

• Create an extension in Configuration → Extensions — the extension is created as

standalone (without being assigned to a user).

Creating a standalone extension

If you have a phone which is not used by any particular user, you can create a standalone

extension for it.

1. In the administration interface, go to Configuration → Extensions.

2. Click Add → Add Extension.

3. Type an extension number.

The field suggests an unused extension. You can change the extension number manually

if necessary.

4. Save the settings.

http://kb.kerio.com/article/using-pbx-services-893.html
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SIP username and SIP password

Each extension has a SIP username and a SIP password. Kerio Operator uses SIP

usernames and SIP passwords for authentication of phones to Kerio Operator. You use SIP

username/password for connecting softphones or hardware phones to Kerio Operator (read

more in the Configuring multiple registration of an extension article).

SIP usernames/passwords cannot be used to login into Kerio Operator or Kerio Operator client.

Using SIP username/password

1. In the Kerio Operator administration interface, go to Configuration → Extensions.

2. Select an extension and click Edit.

3. In the Edit Extension dialog, you can see fields SIP username and SIP password.

4. To display the SIP password, click the keys icon.

Figure 1 SIP username and SIP password

Now you can view the SIP username/password and use it for connecting a phone to Kerio

Operator.

http://kb.kerio.com/article/configuring-multiple-registration-of-an-extension-906.html
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Configuring multiple registration of an extension

Multiple registration overview

Do you want to use your extension with various phones? Softphone in your cell phone or IP

phone in your smartphone? The solution is multiple registration.

Multiple registration (in contrary to assigning more extensions to one user) gives user

the possibility to call from the same extension any time they make a call.

Example:

User Brenda Roar with username broar working at the Marketing department uses the

extension 224. When necessary, she also works from home. She uses the following to

communicate:

1. She has an automatically provisioned phone Cisco 7940 in his office.

2. She has X-Lite softphone on her home computer.

3. Occasionally, when connected via WiFi, she uses a SIP client on her mobile phone.

With correct settings of multiple registration that will be described in the following chapter

she can use all the before-mentioned methods to authenticate.

Creating multiple registrations in Kerio Operator 2.0 and later

1. Open section Configuration → Extensions.

2. Select Brenda Roar’s extension (224). Click on Add → Add Another Registration.

3. A new registration is added to the user table. Add another registration. The result should

be similar to the following image 2.
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Figure 1 Extensions → Add Another Registration

Figure 2 Extensions → Multiple registration

4. Double-click the 224p1 registration and note the SIP username and SIP password from the

opened dialog (see figure 3).

5. Click OK.

6. In the X-Lite settings (detailed info for installation can be found in article Configuring the

X-Lite software phone), enter the newly generated string into User ID and the SIP password

into Password.

7. Repeat steps 4 to 6 for the second registration for the SIP client on a mobile phone.

http://kb.kerio.com/article/configuring-the-x-lite-software-phone.html
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Figure 3 Edit Extension → Login information for X-Lite

How to create multiple registrations in Kerio Operator 1.2 and later

1. Open section Configuration → Extensions.

2. Look up Brenda Roar’s extension 224 and open the extension edit dialog.

3. Check the Allow multiple registrations and set the Number of manually configured

phones to 2 (X-Lite and SIP client in the mobile phone).

4. Click on SIP Usernames and note the strings (with letter u at the end).

5. Save the settings.

6. In the SIP client and softphone configurations, enter the newly generated strings as User

IDs.
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Displaying, hiding and overriding phone numbers

How to hide user’s phone number

You can hide user’s phone number for outgoing calls as follows:

1. Go to section Configuration → Extensions.

2. Open the Edit Extension dialog.

3. Go to tab Advanced and select the Hide option in the Caller ID for outgoing calls section.

Some registrars (VoIP service providers) do not allow to hide phone numbers. If you

are connected through such registrar, the settings will not work (see article Connecting to

VoIP service provider).

Example:

Mr Peter Prank, General Manager at Live And Let Laugh Inc, often needs to make calls from

his extension to management departments of significant customer companies. However,

according to the book, only his personal assistant Alessandra G. Uffaw and the company

operators Joan Giggle and Brian Snigger are allowed to know the extension number. For

outgoing calls from Mr Prank’s extension, Thomas Punchline sets the number as hidden.

How to change phone number to display

You can change user’s phone number for outgoing calls as follows:

1. Go to section Configuration → Extensions.

2. Open the Edit Extension dialog.

3. Switch to the Advanced tab.

4. Select the Override with option and select a new extension in the list.

Example:

Though either Mr Oscar Jape, Sales Department Manager at Live And Let Laugh Inc, does

not want customers to contact him directly, it is not very desirable for them not to see

who is calling and possibly call back if they need to discuss any invoicing or orders issues.

Frederic Jovial, the local market call assistant, is authorized to communicate with Mr Jape’s

customers. The telephony system administrator therefore sets outgoing calls from Mr Jape’s

extension to display direct number to Mr Jovial’s extension on the callees’ phone.

http://kb.kerio.com/article/connecting-to-voip-service-provider.html
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Connecting Kerio Operator to directory service

Which directory services are supported in Kerio Operator

Kerio Operator supports the following directory services:

• Microsoft Active Directory

• Apple Open Directory

What is the connection used for

In practice, mapping accounts from a directory service provides the following benefits:

Easy account administration

Apart from the internal database of user accounts, Kerio Operator can also import

accounts and groups from an LDAP database. Using LDAP, user accounts can be managed

from a single location. This reduces possible errors and simplifies administration.

Online cooperation of Kerio Operator and directory service

Additions, modifications or removals of user accounts/groups in the LDAP database are

applied to Kerio Operator immediately.

Using domain name and password for login

Users may use the same credentials for Kerio Operator client login and domain login.

• Mapping is one-way only, data are synchronized from directory service to Kerio

Operator. Adding a new user in Kerio Operator creates a local account — it will not

be duplicated into the directory service database.

• When creating user accounts in a directory service, ASCII must be used to specify

usernames. If the username includes special characters or symbols, user may not

be able to login to Kerio Operator client or the administration interface.

• If you disable users in Microsoft Active Directory, they are also disabled in Kerio

Operator (they will not be able to login to Kerio Operator client, make or receive

calls with their extensions).

• If you disable users in Apple Open Directory, they stay enabled in Kerio Operator.
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Phone extensions can be managed in a directory service (if available) or locally in Kerio

Operator. Select the most convenient option.

How to connect to directory service

To map users from a directory service:

• Connect to directory service in section Integration → Directory Service.

• Activate users in section Configuration → Users.

All information about directory services can be found in the Config log.

Microsoft Active Directory

In the administration interface, go to Integration → Directory Service.

1. Check the Map user accounts from a directory service option and select your directory

service type.

2. In the Domain name field, enter the name of your Microsoft Active Directory domain —

the domain name is then copied in other necessary fields.

3. In the Hostname field, enter the DNS name or IP address of the Microsoft Active Directory

server. If you have a backup server, enter its name in the Secondary hostname filed.

4. In the Username and Password fields, enter the authentication data of a user with at least

read rights for Microsoft Active Directory database. Username format is user@domain.

5. Within the communication of the Microsoft Active Directory database with the PBX,

sensitive data may be transmitted (such as user passwords). For this reason, it is

recommended to secure such traffic by using SSL. To enable LDAPS in Microsoft Active

Directory, it is necessary to run a certification authority on the domain controller that is

considered as trustworthy by Kerio Operator.

6. The rest of the items in the dialog are completed automatically. Do not change them

unless you have a special reason to do so. These items are Microsoft Apple Open Directory

domain name and Kerberos Realm which has to match the Microsoft Active Directory

domain name, written in capital letters.

Apple Open Directory

In the administration interface, go to Integration → Directory Service.

1. Check the Map user accounts from a directory service option and select your directory

service type.

2. In the Domain name field, enter the name of your Apple Open Directory domain — the

domain name is then copied in other necessary fields.
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3. In the Hostname field, enter the DNS name or IP address of the Apple Open Directory

server. If you have a backup server, enter its name in the Secondary hostname filed.

4. In the Username and Password fields, enter the authentication data of a user with at least

read rights for Apple Open Directory database. Username format is user@domain.

5. Within the communication of the Apple Open Directory database with the PBX, sensitive

data may be transmitted (such as user passwords). For this reason, it is recommended to

secure such traffic by using SSL. To enable LDAPS in Apple Open Directory, it is necessary

to run a certification authority on the domain controller that is considered as trustworthy

by Kerio Operator.

6. The rest of the items in the dialog are completed automatically. Do not change them

unless you have a special reason to do so. These items are Apple Open Directory domain

name and Kerberos Realm which has to match the Apple Open Directory domain name,

written in capital letters.

How to activate users from a directory service

Once the mapping is set, select individual users and map them to the PBX. This is how to map

users:

1. Open the Configuration → Users section.

2. In the main window, click on Add → Add from Directory Service.

3. In the dialog, select all users you wish to map (you can also add users later) and click Next.

4. If users in the directory service have phone extensions assigned, you can either keep them

or disable them. If you disable them, you have to assign new extensions. You can do it,

for example, while changing your dial plan.

5. Click on Finish. Activated users are displayed in section Configuration → Users.

Only extensions in attributes telephoneNumber (Microsoft Active Directory, Apple

Open Directory) and otherTelephone (Microsoft Active Directory) can be mapped (are

displayed). If you create special attributes in a directory service for your phone numbers,

you will not be able to map such extensions.
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Configuring automatic phone provisioning

Phone provisioning overview

Phone provisioning is used for automatic configurations of selected hardware SIP phones.

Phone provisioning means:

• phone automatically connects to the PBX after booting and is assigned a phone

extension,

• extensions are managed in the administration interface,

• if you confirm or plan it, the system will perform an automatic restart of provisioned

phones if needed,

• phone firmware is automatically updated,

• displaying a company logo on hardware phones supported by Kerio Operator

• accessing company contacts through LDAP

Automatic firmware update is not supported for the Polycom phones and the original

Cisco phones (Cisco SPA is supported). However, there is a possibility to update the

firmware. You can upload all necessary files to folder /var/tftp in Kerio Operator

manually. For detailed information see article Uploading configuration files to Kerio

Operator TFTP server.

Use of phone provisioning is not always suitable. If Kerio Operator is located and

runs in the Internet, for security reasons we do not recommend to use automatic phone

provisioning.

What you need

1. In your local network, you need a DHCP server supporting parameter 66 (TFTP server

address). Enter the address of Kerio Operator in this parameter.

http://kb.kerio.com/1489
http://kb.kerio.com/1489
http://kb.kerio.com/1489
http://kb.kerio.com/1489
http://kb.kerio.com/1489
http://kb.kerio.com/1489
http://kb.kerio.com/1489
http://kb.kerio.com/1489
http://kb.kerio.com/1489
http://kb.kerio.com/1489
http://kb.kerio.com/1489
http://kb.kerio.com/1490
http://kb.kerio.com/1490
http://kb.kerio.com/1490
http://kb.kerio.com/1490
http://kb.kerio.com/1490
http://kb.kerio.com/article/uploading-configuration-files-to-kerio-operator-tftp-server.html
http://kb.kerio.com/article/uploading-configuration-files-to-kerio-operator-tftp-server.html
http://kb.kerio.com/article/uploading-configuration-files-to-kerio-operator-tftp-server.html
http://kb.kerio.com/article/uploading-configuration-files-to-kerio-operator-tftp-server.html
http://kb.kerio.com/article/uploading-configuration-files-to-kerio-operator-tftp-server.html
http://kb.kerio.com/article/uploading-configuration-files-to-kerio-operator-tftp-server.html
http://kb.kerio.com/article/uploading-configuration-files-to-kerio-operator-tftp-server.html
http://kb.kerio.com/article/uploading-configuration-files-to-kerio-operator-tftp-server.html
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DHCP server integrated in Kerio Control supports parameter 66.

2. Only selected phones support automatic phone provisioning.

3. Appropriate settings need to be done in Kerio Operator.

If you wish to connect a phone which is not currently supported in Kerio Operator,

you cannot use automatic provisioning. The configuration must be done on the hardware

phone.

How to add a phone

1. In the administration interface, go to Configuration → Provisioned Phones → Hardware

Phones.

2. Click Provisioning Settings. The configuration dialog windows is opened.

3. Check the Enable provisioning option. The option must be checked.

4. Check option Create new extension for newly registered phones in case you create users

locally (do not map them from a directory service).

The Create new extension for newly registered phones option is checked

by default. If you uncheck it, you cannot use automatic remote phone restart —

you will have to restart phones manually if needed.

5. Each telephone must be authenticated when connecting to the PBX. Extension number and

password are used for SIP authentication (Master Password in this case). Option Master

password for phones is enabled enables to create one SIP password for all provisioned

phones. The password is saved in the configuration file which is sent to the phone upon

the first connection to the network and the phone will use this password to authenticate

at Kerio Operator.

If you disable option Master password for phones is enabled, all phones will have their

own SIP passwords (it can be viewed in the configuration dialog of each phone).

Now the general environment for the provisioned phones is configured. Once a phone is

connected to your network, it will be listed in section Provisioned Phones.

http://kb.kerio.com/article/configuring-parameter-66-in-dhcp-server-in-kerio-control.html
http://kb.kerio.com/article/configuring-parameter-66-in-dhcp-server-in-kerio-control.html
http://kb.kerio.com/article/configuring-parameter-66-in-dhcp-server-in-kerio-control.html
http://kb.kerio.com/article/configuring-parameter-66-in-dhcp-server-in-kerio-control.html
http://kb.kerio.com/article/configuring-parameter-66-in-dhcp-server-in-kerio-control.html
http://www.kerio.com/operator/technical-specifications
http://www.kerio.com/operator/technical-specifications
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Adding phones manually

Phones which are not connected to the network can also be provisioned. You may do so

manually — you need the phone’s hardware address and the type of the phone (see figure 1).

The procedure is described below:

Figure 1 Connecting a phone manually

1. In section Configuration → Provisioned Phones, click Add.

2. This opens a dialog which requires the hardware address of the phone (MAC address of

the network card in the phone). The address may lack the colons (see figure 1). Once you

save it, the colons will be added automatically.

3. Select the correct type of the hardware phone (special configuration scripts are created

according to the phone type).
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4. (Optional) Set a label of the phone (for example the name of your company).

The upper label on the phone display.

5. Assign the phone user or users who will use it (see figure 1).

If you do not know to which person the extension will be assigned, check

option Generate new extension number and the extension will be assigned

automatically. Phones without extensions assigned cannot be provisioned.

Importing from CSV file

Phones can be imported from a CSV file. Data in the file must follow certain rules:

• hwAddress — hardware address of the phone,

• phoneManufacturer — name of the phone’s manufacturer,

• phoneType — phone type,

• extension1; extension2; ... — extensions assigned to the phone. The maximum number

of extensions depends on the phone type.

Each phone uses one line and all items are separated by a semicolon.

The file may look as follows:

00:1a:a0:be:1e:cd;Cisco;7940;111;112

00:1b:b0:cd:e1:ca;Cisco;7960;115

00:1c:c0:ab:a2:24;Linksys;SPA942;113;114

Import data from a CSV file as described below:

1. In section Configuration → Provisioned Phones, click on Advanced → Import from a

CSV file.

2. This opens dialog Import from a CSV file — click on Upload CSV file.

3. If the data in the file are correct, a list of all the phones and extensions is displayed. Check

those you want to import.

4. Click OK.

5. The imported phones are displayed in the Provisioned Phones table.
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Restarting provisioned phones

When you change configuration which affects provisioned phones, the phones need to be

restarted (for example, when you create a new call route). When you do so, a dialog window

recommending phone restart is displayed. You can do it immediately or wait for a more

convenient time (for example to an off-peak time). To restart phones later:

1. Open the Provisioned Phones section.

2. Click Advanced → Restart All Phones.

Some Cisco telephones from newer series are not able to restart automatically. In

case of configuration changes you have to check the result. If anything is wrong, restart the

phones manually.

This warning doesn’t relate to Cisco SPA phones.

Firmware

Kerio Operator allows easy installation of phone firmware which are managed through the

phone provisioning:

1. Go to section Configuration → Provisioned Phones and click on the Advanced →

Firmwares button.

2. In the Firmwares and Logos dialog, select a firmware and click Edit.

3. In the Edit firmware dialog, select Verify the firmware.

Kerio Operator vrifies if the firmware includes all important files and information.

4. Click Upload File.

5. This opens a dialog where you select a firmware file and confirm the selection.

6. In the New firmware dialog, select the appropriate phone.

7. Click OK.

The new firmware is installed and after the restart will be installed to phones.

Uploading a phone provisioning module

If you want to change or create a provisioning module (archived templates + PHP scripts which

can change phones behavior), download Provisioning Developer Documentation and read it

carefully.

http://download.kerio.com/dwn/kerio-operator-provisioning-docs.zip
http://download.kerio.com/dwn/kerio-operator-provisioning-docs.zip
http://download.kerio.com/dwn/kerio-operator-provisioning-docs.zip
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When the provisioning module is prepared and archived, upload it to Kerio Operator:

1. Go to administration interface.

2. In section Provisioned Phones, click Advanced → Provisioning Modules..

3. Click Upload.

4. Restart your phones.

Overriding templates

If you want to change a provisioning template (remote changing BLF, speed dials, etc.), go to

the Editing provisioning templates article.

What to do if you want to know the SIP password of your phone

If any of your users needs to know the SIP password of their phone, we do not recommend to

provide them with the Master Password. We have a specific solution:

1. In the administration interface, go to Configuration → Phone Provisioning → Hardware

Phones.

2. Click Provisioning Settings.

3. Disable master password.

Once you disable it, each phone will have their own SIP password which can be shared with

individual users.

Configuring inter-digit timeout

Inter-digit timeout sets the time between dialing the last digit and automatic dial. If your users

complains that it is too long or too short, you can adjust it:

1. Go to the administration interface.

2. In section Provisioned Phones, go to Provisioning Settings.

3. In the Phone Provisioning Settings, set the Inter-digit timeout.

How phone provisioning works

http://kb.kerio.com/1532
http://kb.kerio.com/1532
http://kb.kerio.com/1532
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Figure 2 Automatic HW phone provisioning

This is how the automatic phone provisioning works:

• The telephone boots in the network and sends a DHCP request for an IP address.

• DHCP server accepts the request, assigns an IP address and sends it back in a DHCP

reply. Besides the IP address, the message also contains TFTP (Trivial File Transfer

Protocol) server address — Kerio Operator, in our case.

• SIP phone connects to TFTP server integrated in Kerio Operator.

• Kerio Operator checks whether the phone is new:

• if it is new, Kerio Operator generates a new phone extension for the phone;

• if it is not new, Kerio Operator finds the extension which the phone has used.

• Kerio Operator generates a configuration file suitable for the particular phone type

and sends it via the TFTP protocol.

• The phone is configured using the values it has acquired in the configuration file and

is ready to be used.

Some phones perform an automatic restart during the configuration.
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Accessing company contacts through LDAP on pro-

visioned phones

LDAP configuration overview

New in Kerio Operator 2.2!

Kerio Operator offers searching in your LDAP directory from your provisioned phones.

Cisco79xx phones are not supported.

Polycom phones are not supported with Kerio Connect LDAP.

Connecting to Kerio Connect LDAP/Microsoft Active Directory

1. In the administration interface, go to Provisioned Phones.

2. Click the Provisioning Settings button.

3. In the Phone Provisioning Settings dialog, select option Directory configuration is en-

abled.

4. Click Configure.

5. Click Configuration Wizard.

6. Select type of a service:

• Kerio Connect LDAP — type Kerio Connect hostname, username and password.

• Active Directory — type domain name and hostname of your Active Directory and

credentials of account with at least read-only access to Active Directory,

http://kb.kerio.com/820
http://kb.kerio.com/820
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Figure 1 The Directory Configuration dialog after finishing Kerio Connect LDAP configuration

We recommend to create a special account with read-only access and use

credentials of this account.

7. Save the settings.

8. In Provisioned Phones, click Advanced and restart all provisioned phones.

Phones read the new configuration and start to communicate directly with the LDAP

server.
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Try this feature on your phone. Find a directory on the phone and check the contact list.

For information on how to use your phone directory, read the manual of your phone.

Connecting to LDAP in general

1. In the administration interface, go to Provisioned Phones.

2. Click the Provisioning Settings button.

3. In the Phone Provisioning Settings dialog, select option Directory configuration is en-

abled.

4. Click Configure.

5. Fill the Directory Configuration dialog.

6. Save the settings.

7. In Provisioned Phones, click Advanced and restart all provisioned phones.

Phones read the new configuration and start to communicate directly with LDAP server.

Try this feature on your phone. Find a directory on the phone and check the contact list.

For information on how to use your phone directory, read the manual of your phone.
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Displaying your company logo on the provisioned

phones

Summary

New in Kerio Operator 2.2!

You can display your company logo on hardware phones supported by Kerio Operator.

What you need

• Logo — each phone firmware needs a logo in a different format (see section ??).

• Phones must be provisioned.

Which type of logo do you need

1. In the administration interface, go to Provisioned Phones.

2. Click the Advanced → Logos button.

3. In the Firmwares and Logos dialog, go to tab Logos.

4. Find the firmware type installed on your phones and click Edit.

In Notes, you can find the logo parameters (see screenshot 1).

http://kb.kerio.com/820
http://kb.kerio.com/820
http://kb.kerio.com/820
http://kb.kerio.com/820
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Figure 1 Logo parameters in the Edit Logo dialog

Adding your logo to phones

The Kerio Operator logo is set by default and you have to change it:

1. In the administration interface, go to Provisioned Phones.

2. Click the Advanced → Logos button.

3. Find the logo type for your phone and click Edit.

4. Click Upload File and upload your logo.

5. Close the dialog.

6. In Provisioned Phones, click the Provisioning Settings button.

7. In the Phone Provisioning Settings dialog, select Display logo on the screen.

8. Save the settings.

9. Restart all phones manually.
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Provisioning for Kerio Operator Softphone

Softphone provisioning overview

Auto-provisioning and its functionality is described in a special article — Configuring

automatic phone provisioning.

This article describes auto-provisioning of Kerio Operator Softphone.

Prerequisities

• Kerio Operator must have a DNS name.

• Kerio Operator must use a valid SSL certififcate signed by a certification authority. The

certificate name must correspond with the Kerio Operator DNS name.

Configuring provisioning for Kerio Operator Softphone

First, to users who want to use Kerio Operator Softphone, add a new extension or a new

registration of their existing extension.

Second, add users to provisioning:

1. In the administration interface, go to Configuration → Phone Provisioning → Softphones

2. Click Add.

3. In the Select User dialog, select the user who wants to use Kerio Operator Softphone.

4. Save the settings.

Third, users must configure their mobile devices and connect to Kerio Operator.

Configuring a dial plan

Users with Kerio Operator Softphone want to use their contact list, where phone numbers are

stored in different formats. The Dial Plan translates phone numbers from the format used in

a user’s contact lists to the format that can be dialed via your Kerio Operator PBX:

1. In the administration interface, go to Provisioned Phones → Softphones.

2. Click Dial Plan Configuration.

3. Click Add to create a new rule.

http://kb.kerio.com/product/kerio-operator/server-configuration-kerio-operator/configuring-automatic-phone-provisioning-820.html
http://kb.kerio.com/product/kerio-operator/server-configuration-kerio-operator/configuring-automatic-phone-provisioning-820.html
http://kb.kerio.com/product/kerio-operator/server-configuration-kerio-operator/configuring-automatic-phone-provisioning-820.html
http://kb.kerio.com/product/kerio-operator/server-configuration-kerio-operator/configuring-automatic-phone-provisioning-820.html
http://kb.kerio.com/product/kerio-operator/server-configuration-kerio-operator/creating-extensions-1271.html
http://kb.kerio.com/product/kerio-operator/server-configuration-kerio-operator/creating-extensions-1271.html
http://kb.kerio.com/product/kerio-operator/server-configuration-kerio-operator/configuring-multiple-registration-of-an-extension-906.html
http://kb.kerio.com/product/kerio-operator/server-configuration-kerio-operator/configuring-multiple-registration-of-an-extension-906.html
http://kb.kerio.com/product/kerio-operator/server-configuration-kerio-operator/configuring-multiple-registration-of-an-extension-906.html
http://kb.kerio.com/product/kerio-operator/server-configuration-kerio-operator/configuring-multiple-registration-of-an-extension-906.html
http://kb.kerio.com/product/kerio-operator/server-configuration-kerio-operator/configuring-multiple-registration-of-an-extension-906.html
http://kb.kerio.com/product/kerio-operator/server-configuration-kerio-operator/configuring-multiple-registration-of-an-extension-906.html
http://kb.kerio.com/product/kerio-operator/beta-rc-kerio-operator/configuring-kerio-operator-softphone-1320.html
http://kb.kerio.com/product/kerio-operator/beta-rc-kerio-operator/configuring-kerio-operator-softphone-1320.html
http://kb.kerio.com/product/kerio-operator/beta-rc-kerio-operator/configuring-kerio-operator-softphone-1320.html
http://kb.kerio.com/product/kerio-operator/beta-rc-kerio-operator/configuring-kerio-operator-softphone-1320.html
http://kb.kerio.com/product/kerio-operator/beta-rc-kerio-operator/configuring-kerio-operator-softphone-1320.html
http://kb.kerio.com/product/kerio-operator/beta-rc-kerio-operator/configuring-kerio-operator-softphone-1320.html
http://kb.kerio.com/product/kerio-operator/beta-rc-kerio-operator/configuring-kerio-operator-softphone-1320.html
http://kb.kerio.com/product/kerio-operator/beta-rc-kerio-operator/configuring-kerio-operator-softphone-1320.html
http://kb.kerio.com/product/kerio-operator/beta-rc-kerio-operator/configuring-kerio-operator-softphone-1320.html
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4. Save the rule and click Test in the Dial Plan Configuration dialog.

5. If you need more rules, create another one.

6. Sort rules from specific to general.

Rules are applied from top to bottom.

7. Save the settings.

Creating rules

You can use the following characters when creating new rules.

Character Description

0 to 9 digits

x a single wildcard

*#+ Keyboard symbols

[ ] A collection that can include a range. For example [6-9] means 6 7 8 9. Or

[136-9] means 1 3 6 7 8 9.

. Repeat the last element 0 or more times. For example, with the pattern “12.” the

following input will match: 1 (The “2” is repeated zero times) 12, 122, 1222 and

so on

Table 1 Characters for your dial plan

Example 1: International calls from USA

Match number: +x.

Remove prefix: +

Add prefix: 011

The following image describes a scenario when you wan to call from the USA (prefix 011) to

GB (prefix +44) and outgoing prefix of your company is 9.
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Figure 1 International calls from USA to GB

Example 2: Outgoing prefix 9

Match number: x.

Remove prefix: leave empty.

Add prefix: 9

Example 3: International calls in Europe (replacing “+” by “00”)

Match number: +x.

Remove prefix: +

Add prefix: 00
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Configuring parameter 66 in DHCP server in Kerio

Control

What is parameter 66 in a DHCP server?

The DHCP protocol assigns IP addresses. Apart from these addresses you can also send

additional parameters via the DHCP protocol. Parameter 66 configures the TFTP server

address.

How to set parameter 66 in Kerio Control

1. In the administration interface, go to section DHCP server.

2. If you use the automatically generated scopes, use Click to configure scopes manually.

3. Select a scope and open its settings (the Edit Scope dialog).

4. Click Add.

5. Add parameter 66.

6. Type an IP address through which Kerio Operator communicates.

http://en.wikipedia.org/wiki/Trivial_File_Transfer_Protocol
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Uploading configuration files to Kerio Operator

TFTP server

Why to use phone or other device configuration file

• phone provisioning of unsupported devices (hardware phones or other devices with a

TFTP client)

• phone firmware upgrade

• BLF configuration, ring tones (different ring tones for different phones)

• password change for all extension assigned to one phone

Obtaining the configuration file

The following instructions will come in handy, if you wish to change the configuration file of

a provisioned phone:

1. In the administration interface, go to Configuration → Phone Provisioning.

2. Right-click the phone whose configuration file you wish to download.

Figure 1 Downloading the configuration
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3. Click Download Configuration and select the interface.

Each interface has a different configuration — different IP addresses.

4. The ZIP file with the current configuration will be automatically saved on your computer.

Uploading new or changed configuration files to Kerio Operator

What you need

The file must be uploaded via SSH using SCP.

Locate configuration files to /var/tftp

How to enable SSH in Kerio Operator

Follow these instructions:

1. In the administration interface, go to section Status → System Health.

2. Click Tasks while pressing the Shift key.

3. Select Enable SSH.

4. Connect to Kerio Operator via SCP (use for example WinSCP for Windows) and upload the

file via SSH using SCP.

For access use username root and password of a Kerio Operator administrator.

http://winscp.net/eng/download.php
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Connecting to VoIP service provider

How to connect Kerio Operator to the outside world

Kerio Operator can be connected to an SIP server of your VoIP service provider or to a standard

analogue network. This article deals with the first option — connecting to a VoIP service

provider.

What information to get from your provider

Before you configure an interface, you need to know:

• telephone number or numbers from your SIP provider,

• DNS name of SIP server and the port (usually 5060 for TCP and UDP) on which it

communicates (you get the information from your provider),

• username and password for authentication to the SIP server of the provider (you get

the information from your provider),

• at least one internal extension defined in Kerio Operator (preferably an employee who

will redirect the calls).

How to add communication interface

To configure an interface, you have to configure call routing. Once you configure routing of

incoming calls, routing of outbound calls will be configured automatically.

1. In the administration interface, go to Configuration → Call Routing and click Add SIP

interface. This opens the configuration wizard.

2. Enter a name for the interface (e.g. provider name). The name must not contain spaces,

national and special characters and must be unique.

3. Select New provider. The configuration differs for settings with one number, multiple

numbers and an SIP trunk with an interval of phone numbers:

One number

1. If you acquired one phone number from your provider, enter the number in the New

provider → With external number field (in a pattern supplied by your provider) and click

Next.

2. Select an extension for the operator who will direct all external calls made to the number

from your provider to internal extensions created in Kerio Operator.
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3. In the Prefix to dial out field, enter a prefix to be used for outgoing calls. The prefix is

used by Kerio Operator to route calls to the SIP server of your provider.

4. Click Next.

5. Type data acquired from your provider (DNS name and port of the SIP server and username

and password for authentication).

6. Check Required to register with Registrar, the first time registration to an SIP server is

required by the majority of providers.

7. If the user ID differs from the telephone number, type it in the user ID field.

Some registrars that require these settings do not allow hiding phone

numbers (extensions settings: Configuration → Extensions → add or edit ex-

tension dialog → tab Advanced).

Example:

There are many calls received at Live And Let Laugh Inc every day — calls from salesmen,

business partners, customers, authorities, private calls. One of the solutions of where to

direct all calls is to use the extension of the company assistants Joan Giggle and Brian

Snigger, depending who is currently on duty. The assistant in service redirects calls or

answer them themselves.

Multiple numbers

1. If you acquired multiple phone numbers from your provider, enter the numbers, separated

by commas, in the New provider → With external number field (in a pattern supplied by

your provider) and click Next.

2. Select an extension for the operator who will direct all external calls made to the number

from your provider to internal extensions created in Kerio Operator.

3. In the Prefix to dial out field, type a prefix to be used for outgoing calls. The prefix is used

by Kerio Operator to route calls to the SIP server of your provider.

4. Click Next.

5. Type data acquired from your provider (DNS name and port of the SIP server and username

and password for authentication).

6. Check Required to register with Registrar, the first time registration to an SIP server is

required by the majority of providers.
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7. If the user ID differs from the telephone number, type it in the user ID field.

Some registrars that require these settings do not allow hiding phone

numbers (extensions settings: Configuration → Extensions → add or edit ex-

tension dialog → tab Advanced).

8. Click OK.

9. In section Call Routing → Interfaces and routing of incoming calls, double-click on one

of the lines with information about mapping of calls to the operator’s extension (figure 1).

Figure 1 Mapping individual numbers to internal extensions of Kerio Operator

10. The Edit Incoming Call dialog is displayed (see figure 2). Click on a line in the Extension

column to map external numbers to internal extensions.
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Figure 2 Mapping individual numbers to internal extensions of Kerio Operator

Example:

If your provider Telephun VoIP gave you a set of telephone numbers which do not cover all

your internal telephone extensions, you can let part of the calls be forwarded by operators

Joan Giggle and Brian Snigger. Then you can map other numbers in pairs.

Interval of numbers

1. If you acquired an SIP trunk with an interval of numbers from your provider, enter it in

this specific pattern. Use X in place of the numbers to vary.

2. Click on Next.

3. Select an extension for the operator who will manually direct all external calls made to the

numbers from your provider to internal extensions unless mapping is configured. Some

numbers from the assigned trunk may be unallocated.

4. In the Prefix to dial out field, enter a&nbsp;prefix to be used for outgoing calls. The prefix

is used by Kerio Operator to route calls to the SIP server of your provider.
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5. Click on Next.

6. Enter data acquired from your provider (DNS name and port of the SIP server and

username and password for authentication).

7. Check the Required to register with Registrar option only if the provider requires

registration. With large number intervals (so called “trunks”), providers usually do not

require registration. The registration is replaced by an IP address of Kerio Operator. The

address must be fixed and the provider needs to know about any changes.

8. If the user ID differs from the telephone number, type it in the user ID field.

Some registrars that require these settings do not allow hiding phone

numbers (extensions settings: Configuration → Extensions →add or edit exten-

sion dialog → tab Advanced).

9. Click OK to confirm settings.

10. Finally, create a rewriting rule for correct mapping of numbers to internal user extensions.

How to map numbers

Mapping external numbers to internal extension is described in a separate article.

Creating Alternative Connection for Route Backup

If you wish to backup your connection to the external network, you have to ensure connection

with another (backup) SIP server or analogue phone extension (PRI/BRI/FXO). You may use a

backup server of your VoIP service provider or you may choose another provider.

If you have a backup server, go to section Configuration → Call Routing and:

1. Create new interface for incoming calls for the backup server.

2. Go to section Routing of outgoing calls and double-click on the main interface (usually

interface 0 in Europe or 9 in the USA). This opens the Edit Outbound Route dialog.

3. In table Use the following external interfaces, add your backup provider.

http://kb.kerio.com/article/mapping-external-and-internal-numbers.html
http://kb.kerio.com/article/mapping-external-and-internal-numbers.html
http://kb.kerio.com/article/mapping-external-and-internal-numbers.html
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Mapping external and internal numbers

Mapping of external and internal numbers

Mapping of internal and external numbers allows to strip the external phone number to an

internal extension. Generally, mapping can strip first 0 to N digits from the number (the

number may be reduced to an empty string) and then add other digits to the number. The

rewriting rule allows to modify the left part of the number as needed by cutting or extending

the number and/or replacing the ciphers in the beginning of the number string. See the

example in figure 1.

Figure 1 Rewriting rule for number 123456789

Mapping numbers for an SIP interface

The following example shows the necessity and profitability of number rewriting (see figure 2):

1. Thomas Punchline, the network administrator at Live And Let Laugh Inc, has acquired

1000 phone extensions from his provider (800225XXX, or 800225001 — 800225999). He

now needs to map these external numbers 800225XXX 1:1 to the internal extensions XXX.

2. For incoming calls, he wants to add a prefix (9 in our example) to calling numbers so that

it is easy for their users to dial back.

Figure 2 Incoming and answer call (read from right to left)
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To achieve this, it is necessary to modify the rule for incoming calls on the interface

(phoney-voip in figure 3):

1. In the administration interface in section Call Routing, Thomas double-clicks on the

routing rule for the interface of the SIP service provider (see figure 3).

Figure 3 Rule for interface phoney voip

2. This displays the Incoming Calls dialog. Modify the called number so that only the

extension remains. Therefore, Thomas strips first 6 ciphers from left (800225 in our

example which leaves extension 111). No prefix is necessary.

3. He does not strip any ciphers from the caller’s number but adds prefix 9 to the left.
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Figure 4 Setting mapping

This setting applies to incoming calls. Incoming calls are such calls when someone

from the external telephone network calls the internal extension of Kerio Operator.

Naturally, there are also rewriting rules for outgoing calls. They are not described in our

example because the initial settings usually suffice.

If you wish to understand the procedure, see article with rules for outgoing calls for

standard telephone interface.

How to map numbers for a standard analogue phone interface

Analogue interfaces use the same principles and, in addition, it is necessary to strip digits in

numbers according to the needs of your telephone provider.

Telephone provider may send the callee’s number whole or in a shortened form (usually last 4

digits) which are sufficient for recognition of the correct extension. Similarly, the provider may

also require whole numbers or numbers in a shortened form (usually last 4 digits). Request

this information from your provider before you start configuring the interface.

The following example explains mapping in detail:

• Company acquired 100 phone numbers from their telephone provider (an interval of
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numbers 55501XX).

• For incoming calls, the provider strips the callee’s number to last four digits (the

number looks like this: 01XX).

• For outgoing calls, the provider requires the caller’s number in a shortened form (last

4 digits).

• Internal extension which will be bound to numbers from the acquired interval of

numbers have format 2XX.

• Prefix for outgoing calls is 9.

Mapping is configured separately for incoming and outgoing calls.

Incoming calls

Figure shows what happens when customer Joshua Spleen calls Adam Rofl in Live And Let

Laugh Inc. Proceed from digit 1 from right.

1. After dialing a number, the call is automatically directed to a telephone provider based on

the number’s prefix.

2. Next, the number is identified by the telephone provider, stripped to the last four digits

and sent to Kerio Operator.

3. According to the rewriting rule, the number is then stripped from left to 2 digits and prefix

2 is added from left. Kerio Operator now works with internal extension 201 and the call is

successfully connected.

4. There may arise a situation where user on extension 201 does not answer the call but

wants to call back later. For that reason, it is necessary to define a callback rule. To

achieve this, add a prefix for calling to external network (otherwise, callback will fail at the

outgoing call interface).

Figure 5 Incoming and answer call (read from right to left)
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Make the following settings to achieve the above mentioned interface behavior:

1. Go to Kerio Operator Administration to section Call Routing and double-click the routing

rule for the standard telephone interface (see figure 6).

Figure 6 Rule for standard telephone interface T1

2. Dialog Edit Incoming Call is displayed. Beer in mind that only the last 4 digits are included

in the string.

Strip the first two digits from left. Add prefix 2 to the stripped number of two digits (see

figure 7). This modification provides the final format of the internal extension (2XX).

Figure 7 Rule for standard telephone interface T1
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3. We do not strip the digits in the calling number but we add prefix 9 from left (see figure 7).

How to configure mapping for outgoing calls

Mapping has to be also configured for outgoing calls. These are calls which are initiated by

Adam Rofl and are directed to customer Taylor Poorteeth. We use the same example as in

configuration of rewriting rules for incoming calls. The configuration will solve the following

problems:

• Strip the prefix for outbound calls that determines to which interface (provider) the

call will be directed (see figure 8).

• Adapt the internal extension which you call from in a way that the number meets the

call criteria of your provider (see figure 9).

This scheme best describes the whole procedure 8 (follow the numbering):

1. Adam Rofl calls number 5550199. Since the called number is external, we must use prefix

for calling external telephone network, which in our case is number 9. Final format of the

number dialed by the user will be 95550199.

2. The rule strips prefix 9.

3. Kerio Operator directs the call to the called number.

Figure 8 Scheme describing how to adapt called number

The following example shows the way the internal extension changes during outgoing calls

(see figure 9)>

1. Adam Rofl calls Taylor Poorteeth. Kerio Operator uses the rewriting rule which

corresponds with the example in section ?? — firstly, Kerio Operator strips digit 2 from

left. This leaves number 01. The rule appends number 01. The final number is 0101.

2. Since the telephone provider requires only the last four digits, the rule is complete and

the number is sent.

3. Telephone provider adds the rest of the number from left and the callee sees the calling

number in format 5550101.
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Figure 9 Scheme describing how to adapt calling number

Make the following settings to achieve the above mentioned interface behavior:

1. In the administration interface in section Call Routing in table Routing of outgoing calls,

double-click the interface (interface with prefix 9 in our example).

2. This opens the Edit Outbound Route dialog; go to the Rewrite Numbers tab.

3. Strip prefix 9 from left in the called number (see figure 10).

4. Strip digit 2 from left in the calling number and add 01 (see figure 10).

Figure 10 Outbound route
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Connecting head office with branch offices

How to connect two PBXs

Kerio Operator can be connected to another PBX via an SIP protocol or analogue connection.

Adding SIP interface

If you wish to configure an interface for communication with another SIP server, follow these

steps:

1. In the administration interface, go to section Configuration → Call Routing and click on

the Add SIP interface button. This opens the configuration wizard.

2. Type a name for the interface (e.g. the name of the other server). The name must not

contain spaces, national and special characters and must be unique.

3. Select Link to another PBX and click Next.

4. Type a prefix for outgoing calls. The prefix tells the PBX which interface the call should

be redirected to. If you enter 3 (the other server uses extensions 3XX), all numbers with

prefix 3 will be directed to this SIP server.

5. Click Next.

6. In the Hostname or IP address and Port number fields, enter the DNS name of the other

SIP server and the port on which it communicates.

7. If the server requires authentication, type valid data in the Username and Password fields.

8. If the server requires registration, checkRequired to register with Registrar.

9. If the user ID differs from the telephone number, type it in the user ID field.

10. Click OK.

11. Finally, create a rewriting rule for correct mapping of numbers to internal user extensions.

Instruction on how to do this can be found in article addressing SIP interface configuration.

http://kb.kerio.com/article/connecting-to-voip-service-provider.html
http://kb.kerio.com/article/connecting-to-voip-service-provider.html
http://kb.kerio.com/article/connecting-to-voip-service-provider.html
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How to configure PRI/BRI/FXO interface

If you wish to configure an interface for communication with another PBX, follow these steps:

1. In the administration interface, go to section Configuration → Call Routing and

double-click on the PRI/BRI/FXO phone interface. This opens the configuration wizard.

2. Type a name for the interface (eg. the name of the server). The name must not contain

spaces, national and special characters and must be unique.

3. Select Link to another PBX and click Next.

4. Type a prefix for outgoing calls. The prefix tells the PBX which interface the call should

be redirected to. If you enter 3 (the other server uses extensions 3XX), all numbers with

prefix 3 will be directed to this PBX.

5. Click Next.

6. In the displayed dialog, select a PBX type, depending on the type used by the other PBX.

7. Click OK.

8. Finally, create a rewriting rule for correct mapping of numbers to internal user extensions.

For more information read article addressing analogue interface configuration.

https://kb.kerio.com/article/configuring-standard-phone-interface.html
https://kb.kerio.com/article/configuring-standard-phone-interface.html
https://kb.kerio.com/article/configuring-standard-phone-interface.html
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Connecting head office with branch offices in Live And Let Laugh Inc

Live And Let Laugh Inc has a head office and a branch office. The head office resides in the

HPR (Happy People Republic), while the branch office is located in BSL (Bliss Seekers Land).

Both offices have their own instance of Kerio Operator installed. Now Thomas needs to

connect both networks and make them behave as a single telephone network.

Phone numbers at Live And Let Laugh Inc use three-figure extensions. While the head office

in HPR employs around fifty people, the branch office in BSL involves just one department

with not even ten people employed there. Thanks to this fact, the range of 99 numbers

is more than enough for this moment. The third number from the right will represent

individual offices. At the branch office in BSL, any of the remaining numbers can be used

(number 1 is used in this example). To keep it consistent and easy-to-remember, both sales

department extensions end with 20 (i.e. 2X).

Local Sales department (headquarters, located in HPR):

• Oscar Jape, Sales Department Manager — extension 120

• Frederic Jovial, sales operator — extension 121

• Mary Merry, sales operator — extension 122

• Mr George Funpoker, sales operator — extension 123

International Sales department (branch office, BSL):

• Anne Kdotte, department manager — extension 320

• Otto Spass, sales operator — extension 321

• Tamara Bellylaugh, sales operator — extension 322

• Veronique Sarcasme, sales operator — extension 323

• Juan Broma, sales operator — extension 324

• Govinda La Scherzo, sales operator — extension 325



71

Configuring standard phone interface

Connecting Kerio Operator to a standard telephone network

Prepare one of the following analogue cards: PRI, BRI or FXO. You can use the card distributed

with Kerio Operator Box series 3000 or use your own card and connect it to your Kerio

Operator server.

Supported analogue cards

• PRI card — number of concurrent calls vary depending on whether you have contract

with an American or European provider.

• T1 (used in the USA) — allows 23 concurrent calls.

• E1 (used in the EU) — allows 30 concurrent calls.

• BRI card — has 4 ports. Each port can operate two concurrent calls.

• FXO card — has 4 ports. Each port can operate one concurrent call.

What to have ready beforehand

Before you configure an interface, you need to know:

• telephone number or numbers form your telephone provider,

• (only PRI/BRI) ISDN type which is used for communication (it usually differs according

to your location — for example, EuroISDN for the EU, Nation ISDN Type 2 for the USA

and so on),

• whether your provider’s PBX requires overlap dialing,

• information whether the PBX sends or requires telephone numbers whole or in the

contracted form,

• at least one internal extension defined in Kerio Operator (preferably an employee who

will redirect the calls).

http://kb.kerio.com/article/mapping-external-and-internal-numbers.html
http://kb.kerio.com/article/mapping-external-and-internal-numbers.html
http://kb.kerio.com/article/mapping-external-and-internal-numbers.html
http://kb.kerio.com/article/mapping-external-and-internal-numbers.html
http://kb.kerio.com/article/mapping-external-and-internal-numbers.html
http://kb.kerio.com/article/mapping-external-and-internal-numbers.html
http://kb.kerio.com/article/mapping-external-and-internal-numbers.html
http://kb.kerio.com/article/mapping-external-and-internal-numbers.html
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Adding analogue communication interface

After connecting an analogue card, configure the interface:

1. In the administration interface, go to section Configuration → Call Routing. If the PRI

card is installed correctly, the Interface and routing of incoming calls table shows one

standard telephone interface.

If the BRI card is installed correctly, the Interface and routing of incoming calls table

shows 4 interfaces (one for each of the four ports).

If the FXO card is installed correctly, the Interface and routing of incoming calls table

shows 4 interfaces (one for each of the four ports).

2. Double-click on an unconfigured interface.The configuration wizard opens.

3. Enter a name for the interface (e.g. provider name). The name must not contain spaces,

national and special characters and must be unique.

One number

1. Enter the number in the New provider → With external number field (in a pattern

supplied by your provider) and click Next.

2. Select an extension for the operator who will direct all external calls made to the number

from your provider to internal extensions created in Kerio Operator.

3. In the Prefix to dial out field, enter a prefix to be used for outgoing calls. The prefix is

used by Kerio Operator to route calls to the PBX of your telephone provider.

4. Click Next.

5. (only PRI and BRI) Select the PBX type in the dialog:

• if you are in the EU, select the EuroISDN option,

• if you are in the USA, select the National ISDN Type 2 option,

Multiple numbers

1. If you acquired multiple phone numbers from your provider, enter the numbers, separated

by commas, in the New provider → With external number field (in a pattern supplied by

your provider) and click Next.

2. Select an extension for the operator who will direct all external calls made to the number

from your provider to internal extensions created in Kerio Operator.
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3. In the Prefix to dial out field, enter a prefix to be used for outgoing calls. The prefix is

used by Kerio Operator to route calls to the PBX of your telephone provider.

4. Click Next.

5. (only PRI and BRI) Select the PBX type in the dialog:

• if you are in the EU, select the EuroISDN option,

• if you are in the USA, select the National ISDN Type 2 option,

6. Save the settings.

7. In section Call Routing → Interfaces and routing of incoming calls, double-click on one

of the lines with information about mapping of calls to the operator’s extension.

8. The Edit Incoming Call dialog is displayed. Click on a line in the Extension column to

map external numbers to internal extensions.

Interval of numbers

1. If you acquired an SIP trunk with an interval of numbers from your provider, enter it in the

New provider → With an external number field in a pattern supplied by your provider.

Use X in place of the numbers which vary.

2. Click Next.

3. Select an extension for the operator who will manually direct all external calls made to

the numbers from your provider to internal extensions created in Kerio Operator unless

mapping is configured.

4. In the Prefix to dial out field, enter a prefix to be used for outgoing calls. The prefix is

used by Kerio Operator to route calls to the PBX of your telephone provider.

5. Click Next.

6. (only PRI and BRI) Select the PBX type in the dialog:

• if you are in the EU, select the EuroISDN option,

• if you are in the USA, select the National ISDN Type 2 option,

7. Click OK.

8. Finally, create a rewriting rule for correct mapping of numbers to internal user extensions.

http://kb.kerio.com/article/mapping-external-and-internal-numbers.html
http://kb.kerio.com/article/mapping-external-and-internal-numbers.html
http://kb.kerio.com/article/mapping-external-and-internal-numbers.html
http://kb.kerio.com/article/mapping-external-and-internal-numbers.html
http://kb.kerio.com/article/mapping-external-and-internal-numbers.html
http://kb.kerio.com/article/mapping-external-and-internal-numbers.html
http://kb.kerio.com/article/mapping-external-and-internal-numbers.html
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Overlap dialing

Some telephone providers require telephone numbers as a whole, others require the telephone

numbers one digit at a time. Ask your provider about their requirements. Follow these steps

to configure the interface:

1. In the administration interface, open the Call Routing section.

2. Double-click the interface to open dialog Configure PRI/BRI/FXO Interface.

3. Switch to the LDAP tab.

4. If overlap dialing is required, check the Overlap dialing option.
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Configuring and using conferences

Telephone conferences overview

Telephone conference is one telephone call of three or more users.

Telephone conferences allow participation of Kerio Operator users and external participants.

To join a conference, participants must dial the conference number and PIN.

You can use two different types of conferences — statically or dynamically configured.

Statically configured conference

Statically configured means that conferences are created in the administration interface and

each new conference uses one extension.

If there is a lack of extensions, use dynamically configured conferences instead.

Configuring statically configured conferences

1. Go to section Configuration → Dial Plan and make sure that the extension you have

selected for the conference is not used.

2. In Configuration → Conferences, click Add. The Add conference dialog is dispayed.

3. Enter the conference extension and its description.

4. In the menu Conference type, choose the Statically configured option.

5. Optional: Limit the number of participants.

6. Each conference can be protected by a PIN required from all participants upon attempting

to enter the conference. If you wish to secure a conference, set a PIN and deliver it to the

members.

7. To enable call recording, select Record Calls.

Please note that call recording is a subject to special laws in many

countries. It maybe illegal in your jurisdiction or require notice to the other party

on the call. Accordingly, you assume all liability for using the call recording

functions and are responsible for notifying all users of this system of this

potential restriction, if applicable.
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Connecting to a statically configured conference

1. Dial the conference telephone number / extension.

2. If the conference is protected, you will be asked to enter the PIN.

To leave the conference, simply terminate the call.

Dynamic conferences

New in Kerio Operator 2.1!

A dynamic conference is created on one extension only. Users set the conference number and

PIN after dialing the extension or the whole telephone number. On one extension, users can

set unlimited number of conferences with different conference numbers.

The disadvantage of dynamic conference is that user has to enter three numbers when dialing

the conference (the extension, the conference number and the PIN).

Configuring dynamic conferences

1. Go to Configuration → Dial Plan and make sure that the conference extension is not used

by a user.

2. In Configuration → Conferences, click Add. The Add conference dialog is dispayed.

3. Enter the conference extension and its description.

4. In the Conference type menu, choose option Dynamic, created on demand.

5. To enable call recording, select Record Calls.

Please note that call recording is a subject to special laws in many

countries. It maybe illegal in your jurisdiction or require notice to the other party

on the call. Accordingly, you assume all liability for using the call recording

functions and are responsible for notifying all users of this system of this

potential restriction, if applicable.

Connecting to a dynamic conference

To connect to an existing conference, enter the conference number and PIN (if required).
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Creating a dynamic conference

1. Dial the conference telephone number/extension.

2. Enter a random number for the conference.

3. Set PIN, if you want to protect your call.

4. Communicate these access numbers to other attendees.

To leave the conference, simply terminate the call.

Where to monitor conference activities

All current calls can be viewed under Status → Conferences.
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Configuring call queues

Call queues overview

Call queues are used to distribute incoming calls between agents.

Figure 1 Call queue

Configuring call queues

1. In the administration interface, go to Configuration → Call Queues.

2. Click Add to open the Add Call Queue dialog. On the General tab, type the new queue

extension number.

3. Select the queue strategy.

4. Click the Agents tab.

5. If you want your agents to log in dynamically, type login and logout code. For example,

12345 to login, and 54321 to logout. The calls will only go to agents logged into the queue.

If you want to assign specific agents permanently to the queue, click Add to select their

extensions.
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Both methods can be combined. One queue may have agents who are

assigned permanently and agents who log in dynamically.

6. Click the Announcements tab.

An announcement can be a pre-recorded message or music that callers hear while waiting

in a call queue. You can import pre-recorded announcements into Kerio Operator (see

article Language settings in Kerio Operator) or record them by going to Configuration →

PBX Services → Record audio (see article Using PBX services).

How to select a queue strategy

• Round robin with memory mode uses circular call distribution. It remembers the last

agent who answered the phone, and new calls are directed to the next agent in the

round queue.

• Ring all agents — calls always ring at all agents until one of them answers the

particular call.

• Ring least recently called agent — the system selects the agents who have not

answered the phone for the longest period.

• Ring agent with fewest calls — the system assigns the call to the agent with the lowest

number of calls answered so far.

• Ring random agent — if you select this option, the system will choose an agent

randomly.

• Ring in order — only for permanently assigned agents. You specify a fixed order

in which they are always selected. This strategy is for companies where all calls

are answered by a receptionist. In case the receptionist is not answering, the call

is directed to the next agent in order (for example, an administration assistant).

What is the difference between permanently assigned and dynamic agents

• Permanent assignment — agent’s extension is assigned permanently to the queue.

• Dynamic login — agents use special code for logging in and out of the queue.

http://kb.kerio.com/article/language-settings-in-kerio-operator-940.html#sect-newlang
http://kb.kerio.com/article/language-settings-in-kerio-operator-940.html#sect-newlang
http://kb.kerio.com/article/language-settings-in-kerio-operator-940.html#sect-newlang
http://kb.kerio.com/article/language-settings-in-kerio-operator-940.html#sect-newlang
http://kb.kerio.com/article/language-settings-in-kerio-operator-940.html#sect-newlang
http://kb.kerio.com/article/using-pbx-services-893.html#sect-autoatdrc
http://kb.kerio.com/article/using-pbx-services-893.html#sect-autoatdrc
http://kb.kerio.com/article/using-pbx-services-893.html#sect-autoatdrc
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Recording calls from call queues

Kerio Operator allows recording calls from call queues. No other module or equipment is

necessary. Setting can be done as follows:

1. Open the Configuration → Call Queues section and select the queue in which you wish to

record the calls.

2. On the General tab, select Record calls.

To play back recorded calls

Please note that call recording is subject to special laws in many countries. It

may not be legal in your jurisdiction, or may require notice to the other party on the

call. Accordingly, you assume all liability for using the call recording functions and are

responsible for notifying all users of this system of this potential restriction, if applicable.

Section Status → Recorded Calls displays all calls recorded from call queues. Select a call to

listen to it, download it to your computer or remove it.

Deleting Recorded Calls

Recorded calls can be periodically deleted once their total size reaches a certain limit. The

limit can be set in section Status → Recorded Calls.

1. Click Advanced → Periodically Remove Old Recorded Calls.

2. In Remove Old Recorded Calls dialog box, enter the maximum size of recorded calls on

a disk (in MB).

Configuring a call queue timeout

The call queue timeout period determines the maximum amount of time a caller can be placed

in a call queue. Configuring the limit prevents from waiting in a queue infinitely.

The timeout limit is unlimited by default. For setting the limit, perform these steps:

1. In administration, go to Configuration → Call Queues.

2. Click Add/Edit.

3. On tab General, set Queue timeout.

4. (Optional) Go to tab Announcements and select Timeout announcement. Such

announcement will play when the limit is reached and should include information about

what happens next (tab Exceptions).
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5. Go to tab Exceptions.

6. Choose an action for exceeded limit:

• Callers receive a busy signal — if announcement was set, recording plays before

call termination.

• Forward to — type an extension. Kerio Operator forwards callers to the extension.

If announcement was set, recording plays.

7. Save the settings.

Timeout is configured. If you want to check your settings, lower the limit to several seconds

and dial the queue from several phones.

Configuring a queue length

A queue length determines max. number of callers in the queue at the same time. Configuring

the limit prevents from waiting too long in the queue.

The queue length is unlimited by default. For setting the limit, perform these steps:

1. In administration, go to Configuration → Call Queues.

2. Click Add/Edit.

3. On tab General, set Queue length.

4. (Optional) Go to tab Announcements, select Full queue announcement. Such

announcement will play when the limit is reached and should include information about

what happens next (tab Exceptions).

5. Click the Exceptions tab.

6. Select an action for exeeded limit:

• Callers receive a busy signal — if an announcement was set, recording plays

before a call is terminated.

• Forward to — type an extension. Kerio Operator forwards callers to the extension.

If an announcement is set, Kerio Operator plays the recording.

7. Save the settings.

The queue length is configured. If you want to check your settings, lower the limit to 1 and

dial the queue from two phones.



Configuring call queues

82

Configuring exit keys

You can set exit keys for each call queue. Callers can use an exit key for transfer to an

extension.

1. In administration, go to Configuration → Call Queues.

2. Click Add/Edit.

3. On tab General, click Edit next to Exit keys.

4. Edit Exit Keys, click Add.

5. In the Add Exit Key dialog, type an exit key (for example 1).

6. Type an existing extension to transfer calls.

7. Type a description.

8. Save the settings.

When users standing in the queue use the exit key, they are transferred to preconfigured

extension.

Configuring call queues without agents

Follow these steps if no agents are logged into the queue:

1. In administration, go to Configuration → Call Queues.

2. Click Add/Edit.

3. (Optional) Go to the Announcements tab, select No agents announcement. Kerio

Operator plays the announcement when there are no agents in the queue.

4. Go to tab Exceptions.

5. Select an action if the queue has no agents:

• Callers cannot join the queue. Callers already waiting are removed — Kerio

Operator disconnects all callers. If No agents announcement is selected, Kerio

Operator plays the recording.

• Callers can join the queue — new callers can connect to the queue. Current callers

stay in the queue. If No agents announcement is selected, Kerio Operator plays

the recording.

• Callers cannot join the queue — new callers cannot connect to the queue. Current

callers stay in the queue. If No agents announcement is selected, Kerio Operator

plays the recording.
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6. If you selected Callers cannot join the queue or Callers cannot join the queue. Callers

already waiting are removed, select one of these actions:

• Callers receive a busy signal

• Forward to — type an extension or external phone number. Kerio Operator

forwards callers to the number.

7. Save the settings.

Settings are complete now. If you want to check your configuration, test these cases:

1. No agent serves the queue. Try to join the queue as a caller.

2. One agent serves the queue. Join the queue as a caller. Agent logs out.

Prioritizing call queues

Agents can operate several call queues. In the following example, an agent is assigned to three

queues.

Figure 2 Operating multiple queues at once
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To help agents identify the queues, you can upload various audio records for each queue. The

record identifying the queue is played to the agent before a call from this queue is connected.

Upload new audio record as follows:

1. Select a call queue or create a new one in section Configuration → Call Queues.

2. In the displayed dialog, go to the Announcements tab.

3. Check the Help agents identify the source queue by playing this announcement and

click on Select.

4. In the Select Audio File dialog box, double-click a record to select it, or upload your own

record to Kerio Operator (it must be in WAV or GSM format). Use the Upload button.

It is also possible to set priorities for individual queues:

1. Open the Configuration → Call Queues section.

2. Select a queue or create a new one.

3. In the displayed dialog, go to the General tab and set the desired priority.

4. Repeat the configuration for other queues.

Queues with higher priority are processed first.

Monitoring active call queues

1. In the administration interface, go to section Status → Call Queues.

2. The top table shows currently active queues.

3. The other tables display agents and callers in a queue. Just select a queue and the details

in table Agents and Callers are updated.

You can also reset the call queue statistics to start from zero. Use the Reset Statistics button.
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Configuring auto attendant scripts

What is auto attendant script

Auto attendant script is a simple collection of voice menus, submenus and announcements

and actions defined for each of them according to the caller’s behavior. It can:

• connect to an extension or voicemail,

• play an announcement,

• navigate through menus and submenus.

Menus can be recorded in various formats. Kerio Operator supports the following formats (see

table 1):

Supported formats Audio format

gsm 8KHz

wav 8KHz, 16 bits per sample, mono (Kerio Operator encodes all WAV files

into this format automatically)

Table 1 Kerio Operator — supported audio formats

How to add new auto attendant script

See the following description of an auto attendant script as an example. Create a script which:

• starts after dialing extension 200,

• contains a voice menu with the following text: “LOL! You have just reached the Live

And Let Laugh company’s hotline (fiendish laugh).”

• For Sales Department, press 1.

• For Quality Assurance Department, press 2.

• For Technical Support Department, press 3.

• If you wish to speak to the receptionist, press 4.
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The Sales Department manages two flagship products of the company. Therefore, two

submenus (Joke Lite, Laugh Home 2012) are created.

• For Joke Lite, press 1.

• For Laugh Home 2012, press 2.

• If you wish to talk to the receptionist, press 3.

Create the same menu for technical support.

Before creating the script, it is necessary to create extensions (in the assigned range

123456XXX) which will be used in the script.

• extension 100 — reception of Live And Let Laugh Inc. One of the receptionists Joan

Giggle or Brian Snigger will connect the calls if the caller makes no selection from the

menu.

• extension 203 — Quality Assurance Department extension (David Jester).

• extension 301 — common extension (you can create a call queue or a ringing group)

for Joke Lite experts, such as Frederic Jovial, George Funpoker, Anne Kdotte.

• extension 302 — common extension for Laugh Home 2012 experts (Tamara Bellylaugh,

Otto Spass, Mary Merry).

• extension 501 — call queue for Joke Lite technical support (Andrew Widegrin).

• extension 502 — call queue for Technical Support of Laugh Home 2012 (Alan Tickle).

Script settings

Configure the script in the administration interface in section Configuration → Auto Atten-

dant Scripts:

1. Click Add and enter the Script extension (extension 200 in our example) and some

description (see figure 1).

2. Click Edit and open the Edit Menu dialog.

3. In the Announcement field, select the recording for the main script. The Select button

offers existing recordings or you can upload your own announcement to the PBX.
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Figure 1 Auto Attendant

If you open the administration interface in Safari browser and you cannot

play any recordings, read article Cannot play voicemails or audio files in Safari.

4. Set Number of playbacks to two which will ensure the menu is played to the caller twice.

5. Once the announcement is played, timeout is started with the default action taken upon

its expiration. Set the timeout to 10 seconds. The default action is the preset hang up

action. This means that if the announcement is played twice and the customer does not

make any selection within 10 seconds, the call will be terminated.

6. Click Add. The Key column states the key which confirms the customer’s choice. Enter

number 1. Enter 1 in this column. Column Action defines what happens when the caller

presses a key on their phone. Select Go to submenu. We need to direct calling customers

to the extension of the product they are interested in (either Joke Lite or Laugh Home

2012). In the Announcement column, you can add a record which will be played upon

pressing the particular key (for example: Stay tuned, now you will be redirected to the Live

And Let Laugh Inc Sales Department). Finish the table according to figure 1.

http://kb.kerio.com/article/cannot-play-voicemails-or-audio-files-in-safari-1208.html
http://kb.kerio.com/article/cannot-play-voicemails-or-audio-files-in-safari-1208.html
http://kb.kerio.com/article/cannot-play-voicemails-or-audio-files-in-safari-1208.html
http://kb.kerio.com/article/cannot-play-voicemails-or-audio-files-in-safari-1208.html
http://kb.kerio.com/article/cannot-play-voicemails-or-audio-files-in-safari-1208.html
http://kb.kerio.com/article/cannot-play-voicemails-or-audio-files-in-safari-1208.html
http://kb.kerio.com/article/cannot-play-voicemails-or-audio-files-in-safari-1208.html
http://kb.kerio.com/article/cannot-play-voicemails-or-audio-files-in-safari-1208.html
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Figure 2 Editing main menu

7. Check Interpret any other input as extension number and dial it. This option allows to

specify a direct extension while the auto attendant script is running.

8. Confirm the settings and return to the Add Auto Attendant Script dialog which is now

similar to the one in figure 1.

9. Click on menu Sales dept.. Again, the Edit menu dialog is opened but now the menu is for

the Sales department. Follow the same procedure as with the main menu. The resultant

menu will look as the one showed in figure 3.

10. Do the same for the Technical Support dept. menu.

Now the script is complete.
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Figure 3 Submenu edit

Time condition

The script can be limited to a specific time interval (office hours of your employees or night

time when no call queue agents are available).

The time ranges (intervals) are configured in section Configuration → Definitions → Time

Ranges. Once you have the time range configured, go back to the Add Auto Attendant Script,

select the menu you wish to limit and click on the Convert to Time Condition button.

Instructions for time condition setting will be better understood through the following

example focusing company’s working hours. Sales department works from 9am to 5pm on

weekdays. Configure the auto attendant script so that when customers call during office hours

they will be connected to a sales department employee and when they call before or later they

will hear a message announcing that the sales department is closed. To create the condition

script, follow these instructions:

1. In the administration interface, go to Configuration → Definitions → Time Ranges.

2. Click Add. Dialog Add Time Range opens.

3. In section Add to a group, select the Create new option and enter a name for the new

interval (for example, Sales Department Office Hours).

4. The Description is optional, for example Weekdays from 9am to 5pm.

5. Select daily in the Type menu and set the desired interval from 9 to 5 in the From and

To fields.
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6. In the Valid on menu, select Weekdays.

7. Click OK to confirm the changes.

8. Open the Configuration → Auto Attendant Scripts section.

9. Click on Add.

10. In the Add Auto Attendant Script dialog, create a corresponding menu (the script created

in the previous section will be used in this example — see figure 1).

11. Select the Sales Department submenu and click Convert to Time Condition.

12. Divide the Sales Department submenu in two time conditions. The first one is played if the

condition is met and the second if the condition is not met. Click on the red highlighted

text Set up the time condition.

Figure 4 Setting the time condition

13. This opens dialog Edit Time Condition. In the For time range menu, select Sales

Department Office Hours.

14. Click on the submenu representing the positive result of the condition. It is currently

called Unnamed. In the dialog Edit Menu just opened, simply add a description (for

example Sales Department condition met).
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15. Click on the submenu representing the negative part of the condition (now it is empty and

unnamed).

16. This opens dialog Edit Time Condition allowing to add a description (for example Sales

Department --- condition not met).

17. Now you can modify the script. For example, in the Announcement field, add a message

announcing that office hours of the Sales Department are from 9am to 5pm on weekdays.

18. Save the submenu. The resultant script is displayed in figure 5.

Figure 5 Time condition applied in the script
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Setting time conditions in auto attendant scripts

Time conditions are best explained in an example

When configuring auto attendant scripts, Bob encountered the following problem. The

company management created a new quality department. The responsible person is Alice. Bob

created a new extension for this department. Alice came to Bob complaining that dissatisfied

customers are calling constantly and he does not even have time for lunch.

Bob knew that Alice needs an auto attendant script which will respect his working hours. And

how to do it?

1. Bob created new time intervals for Alice’s working hours, his lunch break and also for

public holidays.

2. He created records for the following announcements:

Hello. You are calling Live And Let Laugh Inc. We are having a delicious lunch at the

moment. If you call after 1pm, we will gladly hear what you have to say. Talk to ya later!”

“Hello. You are calling Live And Let Laugh Inc. We are off the clock at the moment. Please,

call us on weekdays from 8am to 12pm or after lunch from 1pm to 6pm. We will gladly

hear what you have to say. Talk to ya later!”

“Hello. You are calling Live And Let Laugh Inc. Have a very merry holiday today. If you

wish to make a complaint, call us on weekdays from 8am to 12pm or after lunch from

1pm to 6pm. We will gladly hear what you have to say. Talk to ya later!”

3. He created a new auto attendant script with time conditions.

Setting time intervals for auto attendant scripts

1. In the administration interface, go to section Configuration → Definitions → Time ranges.

2. Add three new time ranges. Two ranges will be of the daily time — Lunch break and

Working Hours. Both ranges will be valid on weekdays.

3. The third range will be absolute. Add the first public holiday when creating the range. Add

also other public holidays and do not forget to add them into the existing group Holidays

(see figure 1).

http://kb.kerio.com/article/using-pbx-services.html
http://kb.kerio.com/article/using-pbx-services.html
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Figure 1 Setting time ranges for working hours, lunch break and holidays

Creating auto attendant scripts in Kerio Operator

The script will follow this scheme:

If Holidays

publicholidays.wav

Else

If Working hours

If Lunch break

lunchbreak.wav

Else

Action: Redirecting to Alice’s extension.

Else

offtheclock.wav

1. In the administration interface, go to Configuration → Auto Attendant Scripts.

2. Add a new script, assign it extension 300 and add a description (Scripts for

complaints desk).

3. Create the first condition: Click Convert to Time Condition.

Double-click on the red link Set up the time condition and in the Edit Time Condition

dialog, select range Holidays (see figure 2). Save the settings.
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Figure 2 Auto Attendant Scripts — creating first condition

4. Now, edit the first part of the condition in dialog Add Auto Attendant Script.

Double-click ).

5. In the Edit Menu dialog, type description Holidays and add a file with the announcement

about a holiday. Set timeout to 5 second (this will suffice) and save the settings.

6. Create the second condition: Select the ) icon and click Convert to Time Con-

dition (thus the “Working hours” condition will be nested into condition “Holidays”).

In the Description field, enter Working hours; in the For time range, select Working

hours (see figure 3). Save the settings.

7. In the Edit Auto Attendant Script dialog under the Working hours line, two new

conditions appear.

8. Create the third condition: Click and click Convert to Time Condition. In the

For time range menu, select Lunch break (see figure 4). Save the settings.
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Figure 3 Auto Attendant Scripts — creating second condition
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Figure 4 Auto Attendant Scripts — creating third condition

9. Double-click the last icon. In the Edit Menu dialog, type description Lunch

break and add a file with the announcement about a lunch break. Set timeout to 5 second

and save the settings.

10. Double-click the icon (last but one in the scheme). In the Edit Menu dialog, type

description Working hours (dial Alice).

You can add an Announcement with information about redirecting to the Complaints

department. Set Timeout to 1 second. In the Default action menu, select Dial extension

number. Type Alice’s extension (211) in the Extension field and save the settings.

11. Double-click the last condition (icon ). In the Edit Menu dialog, type description

After Hours and add a file with the announcement that the Complaints department is

close at the moment. Set timeout to 5 second and save the settings.

If you open the administration interface in Safari browser and you cannot play any

recordings, read article Cannot play voicemails or audio files in Safari.

http://kb.kerio.com/article/cannot-play-voicemails-or-audio-files-in-safari-1208.html
http://kb.kerio.com/article/cannot-play-voicemails-or-audio-files-in-safari-1208.html
http://kb.kerio.com/article/cannot-play-voicemails-or-audio-files-in-safari-1208.html
http://kb.kerio.com/article/cannot-play-voicemails-or-audio-files-in-safari-1208.html
http://kb.kerio.com/article/cannot-play-voicemails-or-audio-files-in-safari-1208.html
http://kb.kerio.com/article/cannot-play-voicemails-or-audio-files-in-safari-1208.html
http://kb.kerio.com/article/cannot-play-voicemails-or-audio-files-in-safari-1208.html
http://kb.kerio.com/article/cannot-play-voicemails-or-audio-files-in-safari-1208.html
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The resultant script is displayed in figure Auto attendant script for the Complaints

department.

Figure 5 Auto attendant script for the Complaints department
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Creating ringing groups

What are ringing groups

Ringing groups are used to make calls ring simultaneously on multiple extensions.

How to add new ringing group

1. In the administration, go to Ringing Groups and click Add.

2. Type the extension number in the Group extension field.

3. In the table, add extensions of all users who will belong to the group.

4. If you wish to direct the call to another person when no one from the ringing group

answers the phone, check Fall back to another extension when the group is not re-

sponding, set timeout and destination extension for fallback.
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Using PBX services

PBX services overview

Kerio Operator has special phone extensions which run the following services:

• Directed call pickup

• Call parking

• Call pickup

• (New in Kerio Operator 2.2) Voicemail — a service extension to access voicemail. Kerio

Operator recognizes which extension is used and you can set if PIN is required or not.

This service is set automatically for provisioned phones.

• (New in Kerio Operator 2.2) Voicemail with login prompt —a service extension to

access voicemail. Kerio Operator is not able to recognize which extension is used.

Users must authenticate with typing their extension and PIN.

• Echo — this option helps you monitor whether phones are correctly connected and

what is the sound delay. Speak to the phone after hearing the automated message. If

done correctly, your message is recorded and played back.

• Music — music plays upon dialing the extension (used for checking the connection).

• Current time — auto attendant tells the current date and time.

• Dial by extension — auto attendant invites the user to enter the extension which the

operator will dial.

• Dial by name — user enters first several letters of the callee’s surname and system

searches among the users created in Kerio Operator and dials the extension.

• Record audio — Kerio Operator starts recording. Thus you can easily create records

for auto attendant scripts in excellent quality.

• Receive fax messages — the service enables you to receive fax to defined email

address. Necessary condition for enabeling the service is entering email address for

receiving faxes in PDF format.

PBX services are placed in the Kerio Operator administration interface in Configuration → PBX

Services.

http://kb.kerio.com/article/configuring-call-pickup.html
http://kb.kerio.com/article/configuring-call-pickup.html
http://kb.kerio.com/article/configuring-call-pickup.html
http://kb.kerio.com/article/configuring-and-using-call-parking.html
http://kb.kerio.com/article/configuring-and-using-call-parking.html
http://kb.kerio.com/article/configuring-call-pickup.html
http://kb.kerio.com/article/configuring-call-pickup.html
http://kb.kerio.com/907
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If you wish to use any service, tick the box next to this service. Extensions offering

the services are disabled by default.

Creating voice files

This chapter shows how to create a records for an auto attendant script easily, fast and in

sufficient quality.

1. Prepare texts.

2. In the administration interface, go to Configuration → PBX Services, enable Record audio

and save the settings.

3. Pick up the handset of your phone which is connected to Kerio Operator.

4. Dial the Record audio service.

5. Say individual voice recordings into the headset.

6. The record is stored in the audio file library in Kerio Operator. You can listen to the

recordings in section Configuration → Auto Attendant Scripts (the Audio File Library

button is in the right bottom corner).

If you open the administration interface in Safari browser and you cannot play any

recordings, read article Cannot play voicemails or audio files in Safari.

http://kb.kerio.com/article/cannot-play-voicemails-or-audio-files-in-safari-1208.html
http://kb.kerio.com/article/cannot-play-voicemails-or-audio-files-in-safari-1208.html
http://kb.kerio.com/article/cannot-play-voicemails-or-audio-files-in-safari-1208.html
http://kb.kerio.com/article/cannot-play-voicemails-or-audio-files-in-safari-1208.html
http://kb.kerio.com/article/cannot-play-voicemails-or-audio-files-in-safari-1208.html
http://kb.kerio.com/article/cannot-play-voicemails-or-audio-files-in-safari-1208.html
http://kb.kerio.com/article/cannot-play-voicemails-or-audio-files-in-safari-1208.html
http://kb.kerio.com/article/cannot-play-voicemails-or-audio-files-in-safari-1208.html
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Configuring and using call parking

What is call parking

Call parking is a special type of call transfer. Parked calls wait for the callee on a special

number.

Example

Joan Giggle needs to answer a question on the phone. She needs to find the information in

another office first.

She parks the call. She goes to the other office and finds the information. On the telephone

in the office, she dials the number of the parked call and answers the question.

Configuring call parking

You park calls on number which consists of:

• PBX service prefix

• parking position number

1. In the administration interface, go to section PBX Services.

2. Double-click Call parking to open the Edit Service dialog box.

3. Check Service is enabled.

4. In the Service extension field, enter the call parking prefix. You can leave the default

prefix setting *5.

We recommend to keep the default prefix. If you change the prefix, inform

the users.

5. Set the timeout (40 seconds by default). When the timeout expires, the call will fall back

to the original extension.

6. Set the number of digits for parking positions.
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We recommend to use the same number of digits as for extensions (your

dial plan). Users can park calls on positions which match their extension numbers.

7. Save the settings.

Call parking is ready.

Using call parking

1. Initiate or answer the call.

2. Use call transfer (transferring calls is described in this article: Hardware telephone basic

usage).

3. Dial the call parking number (e.g. *534).

4. Terminate the call.

To answer a parked call:

1. Pick up the phone.

2. Dial the call parking number (in our example, it is *534).

If nobody answers the parked call before the timeout expires, the call will fall back to the

original extension.

http://kb.kerio.com/article/hardware-telephone-basic-usage-1231.html
http://kb.kerio.com/article/hardware-telephone-basic-usage-1231.html
http://kb.kerio.com/article/hardware-telephone-basic-usage-1231.html
http://kb.kerio.com/article/hardware-telephone-basic-usage-1231.html
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Configuring call pickup

What to use call pickup for

This function enables users to answer a call ringing on an extension on a device at another

extension. The PBX distinguishes between two types of call pickup:

• Call pickup within defined groups (so called rooms) by using specific code (by default,

this code is *8),

• Call pickup by using a special code (by default, this code is **) with the called extension

appended at the end.

How to configure call pickup rooms

1. In the administration interface, go to Configuration → PBX Services, enable Call Pickup

and save the settings. Keep the default pickup code (*8) unless you do have a reason to

change it.

2. Go to Definitions → Call Pickup Rooms and click Add to open dialog Add Call Pickup

Room.

3. Type the name of the department or the office in the Name field.

4. In the table, add all users and extensions that will be able to pick up calls for one another.

5. Make sure the Room is enabled option is checked.

Example:

The Live And Let Laugh company network administrator uses the Add Call Pickup Room

dialog to add a group with room name Local Sales for HPR (Happy people Republic). He

adds all sales assistants for local market and their extensions: Frederic Jovial, Mary Merry,

George Funpoker.

Frederic Jovial has a day off today. His phone is ringing. Thanks to the call pickup rooms

feature, Mary Merry does not need to dash for the Frederic’s desk every time a customer

calls his extension. She simply dials the magic code *8 and serves the customer at her desk.
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How to configure directed call pickup

Directed call pickup is a service allowing to pickup calls directed to any extension at the PBX.

Imagine the following situation:

• the managing director Peter Prank uses extension 101

• the financial director Oscar Jape uses extension 102

• they share an assistant, Ms Alessandra G. Uffaw.

If Alessandra’s phone shows information that someone is calling the managing director (Peter

Prank) during his meeting with the financial director (Oscar Jape), she can accept the call by

dialing **101. Once she picks up the call, she learns that the caller is the International laughter

Association manager and arranges a meeting for him and her company’s executive manager.

A few minutes later, the phone at the desk of the financial director Oscar Jape starts ringing.

Again, the assistant can accept this call at her desk phone. now she enters the code **102 and

recommends the caller (the Cirque de Rire ringmaster) to call Mr Jape back later.

As you can see, by dialing the call pickup code, you can answer a call for any extension of the

PBX.

For directed call pickup, apply settings as described below:

1. In the administration interface, go to Configuration → PBX Services.

2. Enable Directed Call Pickup.

3. Directed call pickup is now fully functional.
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Creating and using speed dial

Speed dial overview

Speed dial is a shortcut for phone numbers (for both the internal extensions and external

phone numbers).

Adding speed dial

Before you begin creating speed dial, select a numerical range you will use. Speed dial must be

different from current extensions. Generally, it is convenient to create speed dial so that they

will not coincide with your dial plan in future.

1. Open Configuration → Speed Dial.

2. Click Add.

3. In the Add Speed Dial dialog box, type a speed dial in the Speed dial extension field.

4. In Dial number, type the callee’s phone number including the prefix for outbound calls.

5. Click OK.

Configuring speed dial with DTMF

New in Kerio Operator 2.2!

The speed dial with DTMF (Dual-tone multi-frequency signaling) is intended for calling special

services likelong distance phone service providers. If you need to place a call via such a service,

you usually need:

• provider’s number (usually it is a toll-free number that starts with 800: 800555333)

• user ID (78901234)

• PIN (8808)

• a number you want to call (011420111222333)

• # character — denotes the end of the number and starts the call.

http://en.wikipedia.org/wiki/Dual-tone_multi-frequency_signaling
http://en.wikipedia.org/wiki/Dual-tone_multi-frequency_signaling
http://en.wikipedia.org/wiki/Dual-tone_multi-frequency_signaling
http://en.wikipedia.org/wiki/Dual-tone_multi-frequency_signaling
http://www.voip-info.org/wiki/view/Long+Distance+Phone+Service
http://www.voip-info.org/wiki/view/Long+Distance+Phone+Service
http://www.voip-info.org/wiki/view/Long+Distance+Phone+Service
http://www.voip-info.org/wiki/view/Long+Distance+Phone+Service
http://www.voip-info.org/wiki/view/Long+Distance+Phone+Service
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When you set the speed dial with DTMF, the number of steps is shortened to dialing the speed

dial extension followed by the number you want to call: 89011420111222333

Configuring speed dial with DTMF

1. In the administration interface, go to Configuration → Speed Dial.

2. Click Add.

3. In the Add Speed Dial dialog box, type a speed dial in the Speed dial extension field (

In our example it is 89.

4. In Dial number, type the provider’s access number including the prefix for outbound calls.

5. Select DTMF tones are enabled.

Once you enable DTMF, the speed dial behaves as a dial-out prefix.

6. In the DTMF prefix field, type the access code and PIN.

Your provider’s IVR system may require a pause between typing the access code and PIN.

Therefore use the w character for a half second pause.

In our example it is 78901234w8808.

7. In the DTMF suffix field, type #

8. Click OK.

Figure 1 Add Speed Dial dialog



30.3 Configuring speed dial with DTMF

107

What is happen if you use the speed dial 89?

You want to call the number 011420111222333.

To place the call, you dial: 89011420111222333. The service will dial the access number

800555333 and once the call is connected, the following DTMF digits are sent:

789012348808 011420111222333 #
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Using paging groups and services

Paging overview

Paging, also known as “intercom” or “public address”, enables Kerio Operator users to

broadcast a message to a user or a group using a phone’s speakers. Phones included in the

paging group or service answer the call automatically, and activate the loud speaker.

Paging works with phones that support auto-answer functionality.

The paging group is a group of users to whom you can make a call with using loud speaker.

The paging service is a prefix for paging. You dial the prefix + an extension to page a particular

user.

Configuring paging groups

1. In the Kerio Operator administration interface, click Paging.

2. Click Add Group.

3. Type the paging group extension.

4. To add members to the group, click Add.

5. (Optional) Check Page only idle extensions.

Paging does not interrupt active calls.

6. (Optional) Check Beep when the call is established.

Your phone beeps when all phones from the paging group are connected.

7. Select audio transfer strategy:

Select only to the receiving party to broadcast the message without giving paging group

members ability to answer.

Select in both directions to enable two-way communication.

8. (Optional) To enable call recording, select Record Calls.

9. Click OK.
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If you want to check your configuration, dial the group extension and do a test call.

Configuring a paging service

1. Go to the administration interface, and click Paging.

2. Click Add Service.

3. Type Paging service prefix.

4. (Optional) Check Page only idle extensions.

Paging do not interrupt active calls.

5. (Optional) Check Beep when the call is established.

Your phone beeps when all phones from the paging group are connected.

6. Decide, if you want to transfer audio only to the receiving party (telephones play the

message and users cannot answer) or in both directions (telephones play the message

and users can answer).

7. (Optional) To enable call recording, select Record Calls.

8. Click OK.

If you want to check your configuration, dial the service prefix and an extension and do a test

call.

Securing paging

Anyone who knows the extension or whole telephone number of the paging group can use this

feature. You can secure your paging groups and service with Call Permissions. You can create

a new call permission group, where paging an extension or a prefix is denied and add people

without permission for using paging:

1. In the administration interface, go to Call Permission Groups.

2. Click Add.

3. In the Edit Call Permission Group dialog, type a group name (for example Paging).

4. Click Add.

5. In the Add Prefix dialog, type a paging extension or service.

6. Click OK.
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7. Go to Configuration → Extensions.

8. Select the user who will have paging disabled and click Edit.

9. In the Call permissions group menu, select the paging rule (in our example it is Paging).

10. Repeat step 9 to disable paging for additional users.

For testing purposes you can add yourself to restricted group called Paging. Try to call the

paging group or service.

List of supported and tested phones

Paging was tested by Kerio Technologies with the following telephones:

• Cisco SPA508G, SPA525G

• Linksys SPA942, SPA922

• Polycom IP335, IP650

• Well SIP-T38G

• Snom 360, 820 and MeetingPoint
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Configuring voicemail

Configure voicemail

Voicemail does not need any configuration. It works automatically once Kerio Operator starts.

All users have forwarding to voicemail inbox enabled by default:

• when unavailable

• when busy

You can change the settings in section Configuration → Users (Ringing rules). Users can also

modify the settings in their Kerio Operator client.

Yyou can find the advanced voicemail configuration in the administration interface in section

Voicemail (see screenshot 1)

Figure 1 Configuration → Voicemail

What is direct access to voicemail inbox and how to configure it

Direct access to users’ voicemail enables the receptionist to connect calls directly to callee’s

voicemail.

1. In the administration interface, go to Configuration → Voicemail → General.

2. Check Allow direct dialing to user’s voicemail boxes.

https://kb.kerio.com/article/redirecting-calls.html
https://kb.kerio.com/article/redirecting-calls.html
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3. Type a prefix in Prefix for direct dialing.

4. (Optional) Set an announcement (greeting message). If a call is redirected to voicemail, the

caller hears a recorded message. This message can consist of two parts:

• Instructions inform callers what they should do next: “Leave a message after the

beep”.

• Message informs callers that the callee is unavailable (the phone is switched off)

or busy (the callee speaks with someone else).

5. Click Apply.

Now the receptionist can dial the extension for direct access followed by the user’s extension.

The caller will be directed to the voicemail box of the person they are calling.

Enabling caller to escape voicemail by dialing 0

If you want to enable escaping voicemail by dialing 0, you must set an extension where the call

is redirected:

1. In the administration interface, go to Configuration → Voicemail → General.

2. Select After pressing the 0 key, dial extension.

3. Type an extension.

4. Click Apply.

Configuring forwarding of voicemail messages to user’s email inbox

To send voicemail messages to email inboxes of the users, you need to set their email

addresses in the administration interface in Configuration → Users.

If the users’ INBOXes are unavailable (the mailserver is down), the user accounts are

disconnected from voicemail and try to reconnect every 5 minutes. Each attempt to connect

is recorded in logs.

My mailserver is Kerio Connect

You can find more information in article Integrating Kerio Connect and Kerio Operator.

http://kb.kerio.com/article/integrating-kerio-connect-and-kerio-operator.html
http://kb.kerio.com/article/integrating-kerio-connect-and-kerio-operator.html
http://kb.kerio.com/article/integrating-kerio-connect-and-kerio-operator.html
http://kb.kerio.com/article/integrating-kerio-connect-and-kerio-operator.html
http://kb.kerio.com/article/integrating-kerio-connect-and-kerio-operator.html
http://kb.kerio.com/article/integrating-kerio-connect-and-kerio-operator.html
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My mailserver is a different SMTP server

1. On your mail server, create a special user which will be used for sending the voicemail

messages. You can name them for example operator.

2. Go to administration interface to Configuration → Voicemail → tab Email and check Send

each message to user’s email.

3. In Mail server hostname, type the SMTP server hostname and click SMTP Configuration.

4. Set the port number of the port used by your SMTP server.

usually 25 for SMTP and 465 for SMTPS

5. Decide, whether to communicate through secured connection. If the configuration of your

mail server allows it, we recommend the encrypted connection to establish more secure

communication.

6. If your SMTP server requires authentication, check Server requires authentication. Use

the username and password for the account you created on your mail server in step 1.

7. Click OK.

8. In Configuration → Voicemail → tab Email, type a valid email address in Sender email

address (so that your antispam rules accept it). The address should also represent the

origin of the message. Example: operator@live-and-let-laugh-inc.com

Configuring the welcome message for callers

If a call is redirected to voicemail, the caller hears a recorded message. This message can

consist of two parts:

Instructions inform callers what they should do next: “Leave a message after the beep”.

Message informs callers that the callee is unavailable.

How to set the greeting message?

1. Open section Voicemail.

2. In the Greeting message menu, select whether the caller will hear the instruction, the

message or both.

Greeting message for the direct dialing is described in the What is direct access to voicemail

inbox and how to configure it section.
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Changing the extension and voicemail PIN

Users use a special extension number to access their voicemail (by default: 50 or 51) and PIN.

To change the extension or enable/disable PIN, go to section PBX Services (see screenshot 2)

and read article Using PBX services.

Figure 2 PBX Services

To set the user’s PIN, go to account configuration in section Configuration → Users to tab

Extensions.

Accessing voicemail

• On your phone, press voicemail button or dial voicemail number and play the message.

• Through Kerio Operator client.

For users of Apple iPhone, iPad or Apple Mac OS X: If you cannot

play your voicemail messages in Kerio Operator client, contact the Kerio

Operator administrator. An invalid certificate may be the reason.

• By forwarding voicemail to your mailbox (to get more information on this option,

contact your network administrator).

Removing voicemail data for selected user

You can remove all local data connected with the particular user.

Local data is:

• voicemail

• custom voicemail greeting message

http://kb.kerio.com/893
http://kb.kerio.com/893
http://kb.kerio.com/893
http://kb.kerio.com/article/cannot-play-voicemails-or-audio-files-in-safari-1208.html
http://kb.kerio.com/article/cannot-play-voicemails-or-audio-files-in-safari-1208.html
http://kb.kerio.com/article/cannot-play-voicemails-or-audio-files-in-safari-1208.html
http://kb.kerio.com/article/cannot-play-voicemails-or-audio-files-in-safari-1208.html
http://kb.kerio.com/article/cannot-play-voicemails-or-audio-files-in-safari-1208.html
http://kb.kerio.com/article/cannot-play-voicemails-or-audio-files-in-safari-1208.html
http://kb.kerio.com/article/cannot-play-voicemails-or-audio-files-in-safari-1208.html
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Local data means that you cannot use this feature when you use the Kerio Connect

integration — voice messages are stored in Kerio Connect in this case.

1. In the administration interface, go to Configuration → Users.

2. Right-click the table heading.

3. In the context menu, select Columns → Voicemail and Columns → Local Voicemail Size.

Figure 3 Table context menu
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4. Right-click the selected user and click Erase Local Voicemail Data.

Figure 4 User’s context menu

If you succeed, there is value 0B in the Local Voicemail Size column.

Managing voicemail via Kerio Operator client

You can administer your voicemail in Kerio Operator client. Login to Kerio Operator client and

go to tab Voicemail.

On this page, you can Play or Remove any selected message or Dial its caller.

Messages in Kerio Operator client can be marked as read. To do it, select the message and

choose Advanced → Mark as Read.

In Kerio Operator client, it is also possible to control the voicemail box by using the standard

context menu. You can open it by right-clicking on a message.

If your company uses Kerio Connect for email communication and you also use

integration with Kerio Connect, information about voicemail status (played, new) will be

synchronized.

Voicemail Menu

After reaching your voicemail, an automatic menu will navigate you through your messages

and other options. You can view the whole menu in picture 5.

http://kb.kerio.com/article/integrating-kerio-connect-and-kerio-operator.html
http://kb.kerio.com/article/integrating-kerio-connect-and-kerio-operator.html
http://kb.kerio.com/article/integrating-kerio-connect-and-kerio-operator.html
http://kb.kerio.com/article/integrating-kerio-connect-and-kerio-operator.html
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Figure 5 Voicemail Menu
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Integrating Kerio Connect and Kerio Operator

What are the possibilities of Kerio Operator and Kerio Connect integration

The integration synchronizes flags which marks whether a voicemail message has been

read/played. If you mark a message as read in Kerio Operator client or if the message is

marked as read after you hear it on your phone, the message will also be flagged as read in

your mailbox (and vice versa).

If integration with Kerio Connect is set, voicemail messages are not stored in Kerio Operator

but in user’s Inbox on the mailserver.

Limitation: You can integrate Kerio Connect with a single Kerio Operator only.

How to configure firewall integrated in Kerio Operator

1. Go to Configuration → Users.

2. In the users’ settings, type their email addresses.

Use the primary email address (not an alias) — otherwise sending of

messages to Inbox will not work.

3. Go to Configuration → Voicemail → Email.

4. Change the SMTP server settings to Integrate with Kerio Connect.

5. Click Configure and type the DNS name of Kerio Connect.

If the IMAP service runs on a nonstandard port in Kerio Connect, enter the

server name including the port number (hostname:12345)

6. Specify the name and password of a user with admin rights for Kerio Connect.

Authentication details are used for the first connection to Kerio Connect and creation of

a special account using JSON-RPC2 API for authentication. Once this special account is created,

the PBX drops the administrator’s name and password.
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To synchronize flags between the two servers, Kerio Operator uses protocol IMAP

with TLS or IMAPS. If Kerio Connect is behind firewall, enable at least one service on standard

port. The IMAP or IMAPS services need to be allowed on Kerio Connect server.

Troubleshooting

If Kerio Connect is protected by firewall, open the ports for the IMAP/IMAPS protocols.

The IMAP/IMAPS services must be running in Kerio Connect.

If you cannot connect Kerio Operator with Kerio Connect, consult the following logs:

• In Kerio Operator, consult the Warning log for any problems with the IMAP service.

• In Kerio Operator, consult the Error log for problems with connection to Kerio

Connect’s IMAP server.

• In Kerio Connect, consult the Mail log for information about delivered voicemails.
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Setting emergency numbers

Emergency numbers overview

When configuring emergency numbers, you can:

• add emergency numbers to the system,

• enable direct dialing (without the prefix for calling external networks).

Call permitions and security restrictions are not applied to emergency numbers.

Configuring emergency numbers

1. In the administration interface, go to Configuration → Call Routing.

2. Click the Emergency Numbers button placed in the lower left corner.

3. Click Overwrite and select the country.

4. If the lists of emergency numbers do not suit your needs, click Add to create your own

emergency numbers.

Enabling direct dialing

All outgoing calls to external networks use a prefix. You can configure an exception for

emergency numbers:

1. In the administration interface, go to Configuration → Call Routing.

2. Click the Emergency Numbers button placed in the lower left corner.

3. Check Enable direct dialing.

4. Select Used outgoing route.

This route will be used for all calls to the emergency numbers.

http://en.wikipedia.org/wiki/Emergency_telephone_number
http://en.wikipedia.org/wiki/Emergency_telephone_number
http://kb.kerio.com/910
http://kb.kerio.com/910
http://kb.kerio.com/909
http://kb.kerio.com/909
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If the direct dialing is enabled, you cannot create extensions which equal the

emergency numbers.
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Configuring SSL certificates

SSL certificates overview

To secure the PBX by SSL/TLS encryption, you need a SSL certificate. SSL certificates

authenticate an identity on a server.

Kerio Operator creates the first self-signed certificate during the installation. The server can

use this certificate but users will have to confirm they want to go to an untrustworthy page.

To avoid this, generate a new certificate request in Kerio Operator and send it to a certification

authority for authentication.

• If you use the Safari browser in your environment (on Apple iPhone, Apple iPad,

Mac OS X systems and on Microsoft Windows), you will not be able to play voice

messages in Kerio Operator client on their devices with a self-signed certificate.

You must have a trustworthy certificate available.

• If you use a self-signed certificate, users with Apple mobile devices will not be able

to play voice messages in Kerio Operator client on their devices. They must have a

trustworthy certificate available.

• To encrypt the communication between Kerio Operator and hardware phones (and

only a self-signed certificate available), you have to import or configure information

in the phones that the invalid certificate is to be ignored.

Creating self-signed certificates

To create a self-signed certificate, follow these instructions:

1. In the Kerio Operator administration interface, open section Definitions → SSL Certifi-

cates.

2. Click New → New Certificate.

3. In the New Certificate dialog box, type the hostname of Kerio Operator, the official name

of your company, city and country where your company resides and the period of validity.

The Hostname and Country entries are required fields.

http://en.wikipedia.org/wiki/Secure_Sockets_Layer
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4. Click OK.

5. To enable the server to use this certificate, select the certificate and click Set as Active.

Creating certificates signed by certification authority

If you wish to create and use a certificate signed by a trustworthy certification authority, follow

these instructions:

1. In the Kerio Operator administration interface, open section Definitions → SSL Certifi-

cates.

2. Click New → New Certificate Request.

3. In the New Certificate Request dialog box, type the hostname of Kerio Operator, the

official name of your company, city and country where your company resides and the

period of validity.

The Hostname and Country entries are required fields.

4. Click OK.

5. Select the certificate and click Export.

6. Save the certificate to your disk and email it to a certification organization.

7. Once you obtain your certificate signed by a certification authority, go to Definitions →

SSL Certificates.

8. Click Import.

9. To enable the server to use this certificate, select the certificate and click Set as Active.

Intermediate certificates

Kerio Operator supports intermediate certificates.

To add an intermediate certificate to Kerio Operator, follow these steps:

1. In a text editor, open the server certificate and the intermediate certificate.

2. Copy the intermediate certificate into the server certificate file and save.

The file may look like this:

MIIDOjCCAqOgAwIBAgIDPmR/MA0GCSqGSIb3DQEBBAUAMFMxCzAJBgNVBAYTAl

MSUwIwYDVQQKExxUaGF3dGUgQ29uc3VsdGluZyAoUHR5KSBMdGQuMR0wGwYDVQ

..... this is a server SSL certificate ...

ukrkDt4cgQxE6JSEprDiP+nShuh9uk4aUCKMg/g3VgEMulkROzFl6zinDg5grz

http://en.wikipedia.org/wiki/Certificate_authority
http://en.wikipedia.org/wiki/Certificate_authority
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QspOQTEYoqrc3H4Bwt8=

-----END CERTIFICATE-----

-----BEGIN CERTIFICATE-----

MIIDMzCCApygAwIBAgIEMAAAATANBgkqhkiG9w0BAQUFADCBxDELMAkGA1UEBh

WkExFTATBgNVBAgTDFdlc3Rlcm4gQ2FwZTESMBAGA1UEBxMJQ2FwZSBUb3duMR

..... this is an intermediate SSL certificate which

signed the server certificate...

5BjLqgQRk82bFi1uoG9bNm+E6o3tiUEDywrgrVX60CjbW1+y0CdMaq7dlpszRB

t14EmBxKYw==

3. In the administration interface, go to section Definitions → SSL Certificates.

4. Import the modified server certificate by clicking on Import → Import a New Certificate.

If you have multiple intermediate certificates, add them one by one to the server

certificate file.
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Language settings in Kerio Operator

Languages in Kerio Operator are:

• Application language — language for the administration interface and for Kerio

Operator client.

• PBX language — “the voice of the PBX”. Voice records which are used for

communication with users (internal and external).

You can also change the type of indication tones according to individual countries (read

section Changing indication tones according to countries).

Changing the application language

The language for the administration and client interfaces can be set in the Admin menu in the

right top corner of the of the application window.

Figure 1 Changing the application language
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Changing the language of the PBX

You can change the default language of the PBX in the administration interface in section

Configuration → Advanced Options → General.

There, you can also upload new language version or different voice records of the same

language (for example, less formal records).

When setting language,bear in mind the following rules:

• Default language set in section Advanced Options → General has lower priority than

settings of individual users in section Users. If users do not have any language set,

the default one is used.

• Default language set in section Advanced Options → General has lower priority than

settings for interfaces for incoming calls (section Call Routing). The language set for

the interface of incoming calls has lower priority than files uploaded to call queues

(see figure 2). If no language is set, the default one is used. The same goes for call

queues.
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Figure 2 Language settings priority

How to change the language for individual users

Thomas Punchline, the network administrator at Live And Let Laugh Inc, faces the following

problem: New employee has arrived in the company. Alessandra G. Uffaw has moved from

the Bliss Seekers Land to the Happy People Republic and cannot speak the Happish language.

She complains she can’t understand her voicemail. Thomas has to switch the PBX language to

the Cravish language for her. Do you need to solve a similar problem? Check the following

example:

1. In the administration interface, go to Configuration → Users.

2. In the user’s settings, go to tab General and change the Phone language.
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How to change the PBX language for a group of users

Thomas was instructed to create a new interface in Kerio Operator and change its language

to the Cravish. He has to create a new interface for incoming calls and set a language for

this interface. He called his VoIP service provider and purchased new phone numbers for

the employees who will communicate with foreign customers. And how he configured Kerio

Operator?

1. In the administration interface in section Configuration → Call Routing , add a new route

for incoming calls.

2. Connect it to the provider, open the edit dialog by clicking on the route in table Interfaces

and routing of incoming calls.

3. Select a language on tab Advanced.

4. Select a country on tab Advanced.

Each country has different stndards for indication tones during calls (e.g. beeps, ringing

tones, etc.).

Figure 3 Changing a language for an entire route
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Setting a different language for a call queue

If you wish to change the language for call queues, not for the entire route, go to section

Configuration → Call Queues.

Language files used in call queues has automatically higher priority than language set

for incoming calls.

How to add a new language to the PBX

If the language sets (voice records) provided in Kerio Operator do not satisfy your needs, you

can download or buy different language sets and import them to the PBX. You can download

the language sets (free or paid), for example, in the following sites:

• http://www.voip-info.org/

• http://downloads.asterisk.org/

You can extract any language set archive and create your own voice records (provided you

keep the file structure).

Changing indication tones according to countries

Each country has different stndards for indication tones during calls (e.g. beeps, ringing tones,

etc.).

You can change the settings in the administration interface.

To select a default country for your PBX, go to table Miscellaneous in section Configuration

→ Advanced Options → tab General.

Figure 4 Changing the default country

Example

Live And Let Laugh Inc has the following configuration:

• Joan Giggle, receptionist and operator, uses extension 100 and wishes the phone to

communicate with her in the Happish language.

• Brian Snigger, receptionist and operator, uses extension 200 and is satisfied with the

default language, which is English.

http://www.voip-info.org/wiki/view/Asterisk+sound+files+international
http://downloads.asterisk.org/pub/telephony/sounds/
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• Phoney VoIP, an interface for incoming calls, is configured in Kerio Operator with the

default language — English. This interface is operated by Brian Snigger.

• Telephun VoIP, an interface for incoming calls, is configured in Kerio Operator for

communication with customers from the Bliss Seekers Land (in Cravish). This interface

is operated by Joan Giggle.

• The default language in Kerio Operator is English.

• Voicemail is enabled and the extension for accessing the voicemail is 50.

Scenario 1:

When Brian Snigger calls Joan Giggle (200 → 100) or when Brian Snigger calls the voicemail

(200 → 50), the automatic announcements are in English.

Scenario 2:

When Joan Giggle calls Brian Snigger (200 → 100) or when Joan Giggle calls the voicemail

(200 → 50), the automatic announcements are in Happish.

Scenario 3:

Customers calling via the Phoney VOIP interfaces will hear announcements in the default

language (English).

Scenario 4:

Customers calling via the Telephun VOIP interfaces will hear announcements in Cravish.

Figure 5 Figure showing the language settings in Live And Let Laugh Inc
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Customization of voice sets

Summary

This summary provides information on how to customize/change voice sets in Kerio Operator.

Details

The Internet provides many sources of localized and customized basic sounds and voice

prompts. Voice sets for various languages can be found at http://www.voip-info.org.

If you wish to customize a voice set (for example, substitute numerals), begin with the basic

sounds:

1. Unpack them.

2. Substitute relevant files.

3. Renew the archive or zip the folder tree (Kerio Operator supports many formats for

archiving).

4. Login to Kerio Operator administration.

5. Open Advanced Options → General.

6. Click Configure which is located next to option Default phone language.

Once you upload a voice and sound set, you can use it for Kerio Operator, individual interfaces

or individual users. For detailed information on this setting, refer to article Configuring

languages in Kerio Operator.

http://www.voip-info.org/wiki/view/Asterisk+sound+files+international
http://kb.kerio.com/article/language-settings-in-kerio-operator-940.html
http://kb.kerio.com/article/language-settings-in-kerio-operator-940.html
http://kb.kerio.com/article/language-settings-in-kerio-operator-940.html
http://kb.kerio.com/article/language-settings-in-kerio-operator-940.html
http://kb.kerio.com/article/language-settings-in-kerio-operator-940.html
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CRM integration using AMI

Asterisk Manager Interface (AMI) overview

Asterisk Manager Interface (AMI) is an interface which enables other applications to connect

to Kerio Operator (which includes Asterisk) and to communicate via the AMI commands. You

can use it to make phone calls. It enables you to:

• dial calls from your CRM system,

• monitor call statuses in your CRM system (e.g., create logs),

• direct calls to another extension or terminate calls in your CRM system.

Connecting Kerio Operator with other applications

You can connect an application with Kerio Operator very easily. The settings are different

for connections with a client (the “server-to-client” connection) and with a server (the

“server-to-server” connection).

How to connect a client application (desktop application for dialing numbers) with Kerio

Operator

To connect the applications, you need the username and password of the client application

user:

1. In the administration interface, go to Configuration → Users.

2. Select a user and open the Edit User dialog.

3. Go to tab Advanced and check option Password for dialer (AMI).

4. Click on the icon and note down the displayed password.

5. Enter the username and password in the client application to authenticate.

How to connect a server (CRM system) with Kerio Operator

You need the authentication data which you enter to your CRM system:

1. In the administration interface, go to Configuration → Integration → General.

2. Click Configure at Third party CTI integration (AMI).

http://www.voip-info.org/wiki/view/Asterisk+manager+API
http://www.voip-info.org/wiki/view/Asterisk+manager+API
http://www.voip-info.org/wiki/view/Asterisk+manager+API
http://www.voip-info.org/wiki/view/Asterisk+manager+API
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3. Check Third party CTI integration is enabled.

4. Click Add.

5. Enter Account name (usually the name of the CRM system).

6. The password is generated automatically. Click on the icon and note down the

password.

7. To test the communication, set the permissions to full control. If the communication is

successful, you may limit the permissions.

Some applications allows you only to originate calls but they use asterisk

commands which require a higher level of permission (usually full control).

8. Login to your CRM system and enter the password for the AMI integration.

9. Test the communication by dialing an extension.

Application we have tried and prepared a configuration guide

OutCALL configuration for dialing from the Microsoft Outlook contacts

What to do when communication fails

Consult the logs in Kerio Operator:

1. In the administration interface, go to section Logs → Debug.

2. Right-click on the log screen and select option Messages in the context menu.

3. This opens the Logging Messages dialog box. Check the AMI (CRM Integration, Desktop

Dialer Applications).

Configure the internal firewall of Kerio Operator

1. In the administration interface, go to section Configuration → Network → Firewall and

check the settings.

2. If your CRM system is located outside your local network, add its IP address in section

Configuration → Definitions → IP Address Groups,

3. Go back to section Configuration → Network → Firewall and select a new IP address

group for the integration with the CRM system.

http://kb.kerio.com/article/configuring-outcall-for-dialing-from-the-microsoft-outlook-contacts-1186.html
http://kb.kerio.com/article/configuring-outcall-for-dialing-from-the-microsoft-outlook-contacts-1186.html
http://kb.kerio.com/article/configuring-outcall-for-dialing-from-the-microsoft-outlook-contacts-1186.html
http://kb.kerio.com/article/configuring-outcall-for-dialing-from-the-microsoft-outlook-contacts-1186.html
http://kb.kerio.com/article/configuring-outcall-for-dialing-from-the-microsoft-outlook-contacts-1186.html
http://kb.kerio.com/article/configuring-outcall-for-dialing-from-the-microsoft-outlook-contacts-1186.html
http://kb.kerio.com/article/configuring-outcall-for-dialing-from-the-microsoft-outlook-contacts-1186.html
http://kb.kerio.com/article/configuring-outcall-for-dialing-from-the-microsoft-outlook-contacts-1186.html
http://kb.kerio.com/article/configuring-outcall-for-dialing-from-the-microsoft-outlook-contacts-1186.html
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Salesforce integration with Kerio Operator

Salesforce integration overview

New in Kerio Operator 2.2!

This article helps you to install and configure Kerio Operator App for Salesforce. If you need

to use Kerio Operator App for Salesforce, go to Using Kerio Operator App for Salesforce.

Kerio Operator App for Salesforce is based on Call Center. The Call Center is an application

embedded in Salesforce and integrates Salesforce with Kerio Operator. For more information

about Call Centers, go to https://help.salesforce.com/.

Kerio Operator App for Salesforce enables:

• click-to-dial

• displaying contacts, accounts and leads during the call

• logging calls into Salesforce

To use Kerio Operator App for Salesforce install the application. You can download it from

Kerio Operator administration interface.

Kerio Operator supports:

• Salesforce Enterprise Edition

• Salesforce Unlimited Edition

Configuring Kerio Operator

Firstly you have to add the Salesforce hostname to Kerio Operator and download Call Center

Definition for Salesforce.

1. In the administration interface, go to Integration.

2. In the Salesforce intergration item, click Configure.

3. Login to your Salesforce and copy the Salesforce hostname (see figure

1)

http://kb.kerio.com/1492
http://kb.kerio.com/1492
http://kb.kerio.com/1492
http://kb.kerio.com/1492
http://kb.kerio.com/1492
http://kb.kerio.com/1492
https://help.salesforce.com/apex/HTViewHelpDoc?id=cti_overview.htm
http://www.salesforce.com/crm/editions-pricing.jsp
http://www.salesforce.com/crm/editions-pricing.jsp
http://www.salesforce.com/crm/editions-pricing.jsp
http://www.salesforce.com/crm/editions-pricing.jsp
http://www.salesforce.com/crm/editions-pricing.jsp
http://www.salesforce.com/crm/editions-pricing.jsp
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Figure 1 Salesforce hostname

4. Paste the hostname to Salesforce hostname.

5. Check if the Kerio Operator’s hostname is complete.

If the field is empty, type a correct Kerio Operator’s hostname.

6. Save the settings.

Figure 2 The result

7. Click Download Call Center Definition.

The communication is based on HTTPS by default. Therefore you should verify

that port 443 is open in both directions and also make sure that the hostname of the

SSL certificate matches the Kerio Operator hostname (read more in the Configuring SSL

certificates article).

Configuring salesforce.com

Configuration is devided into three steps:

• Adding Call Center

• Adding users to the Kerio Operator Call Center

• Installing the Kerio Operator Open CTI Package

http://kb.kerio.com/817
http://kb.kerio.com/817
http://kb.kerio.com/817
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If you are successful, Kerio Operator Call Center will appear and you can continue with adding

users to the call center.

Adding Kerio Operator Call Center

This configuration installs Kerio Operator Call Center in Salesforce.

1. In Salesforce, go to Setup.

Figure 3 Setup

2. In the Quick Find, type Call Centers and click Call Centers in the tree.

Figure 4 Quick Find

3. Skip the help page if it appears.

4. Click the Import button in the All Call Centers page.

5. Click the Choose File button and select the call center definition file you downloaded

earlier.

6. Click Import.
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Kerio Operator Call Center (Kerio Operator App for Salesforce) is installed in Salesforce. You

have to add users to the call center.

Adding users to the call center

This configuration adds users (your colleagues) from Salesforce to Kerio Operator Call Center.

Added users can use Kerio Operator Call Center.

1. In Kerio Operator Call Center, click Manage Call Center Users.

2. Click Add More Users.

3. Leave the form as it is and click Find.

4. Select users and click Add to Call Center.

The users appear in the Kerio Operator Call Center: Manage Users table.

Go to Home in the main menu. You should see the Kerio Operator Call Center application if

your user account is added in the Kerio Operator Call Center.

Installing the Kerio Operator Open CTI Package

Kerio Operator Open CTI Package enables searching salesforce contacts, accounts and leads

in the Kerio Operator Call Center application.

1. Go to Salesforce.

2. In the address bar of your browser, add this string after your Salesforce hostname (in our

case it is https://eu2.salesforce.com/):

packaging/installPackage.apexp?p0=04tb0000000QG2n

The final result will be similar to:

https://eu2.salesforce.com/packaging/installPackage.apexp?p0=04tb0000000QG2n

A Package Upgrade Details page is opened.

3. On page Package Upgrade Details, click Continue.

4. On page KerioOperatorOpenCti, click Next.

5. Select Grant access to all users and click Next.

6. Click Install.

7. If you are successful, the application answers that the installation is complete.
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You can test all features of Kerio Operator App for Salesforce. For details, go to article Using

Kerio Operator App for Salesforce.

Configuring outgoing prefixes

Prefixes for outgoing calls should be consistent with Kerio Operator prefixes. You can

configure it in Kerio Operator Call Center:

1. Go to Kerio Operator Call Center.

2. Click Edit.

3. Change prefixes in the Dialing Options section.

4. Click Save.

Prefixes are the same for Kerio Operator and Salesforce now.

http://kb.kerio.com/1492
http://kb.kerio.com/1492
http://kb.kerio.com/1492
http://kb.kerio.com/1492
http://kb.kerio.com/1492
http://kb.kerio.com/1492
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Configuring backups in Kerio Operator

Backup overview

New in Kerio Operator 2.2!

Watch the Configuring automated backup and remote storage video.

Kerio Operator can back up system settings and data:

• to Samepage.io

• to an FTP server

• to a file (the file can be downloaded from Kerio Operator)

Kerio Operator can backup the following items:

• System configuration — system settings, IVR (auto attendant scripts), users, logos,

firmwares etc.

• Local voicemail data — if you use integration with Kerio Connect, Kerio Operator sends

voicemails via IMAP to Kerio Connect. These voicemails are not backed up.

• SSL certificate — only an active SSL certificate is backed up.

• System logs — all logs from the Logs section.

• Call history log — all logs from the Status → Call History section.

• License — a .key file with your licence.

• Recorded calls —locally saved recorded calls.

You can also back up recorded calls to a remote storage (Samepage.io or an FTP server).

• Custom provisioning files /var/tftp

http://vimeo.com/76216165
http://vimeo.com/76216165
http://vimeo.com/76216165
http://vimeo.com/76216165
http://vimeo.com/76216165
http://vimeo.com/76216165
http://samepage.io/
http://kb.kerio.com/824
http://kb.kerio.com/824
http://kb.kerio.com/824
http://kb.kerio.com/824
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Saving backups to Samepage

Kerio Operator can automatically backup to Samepage.io.

1. Create a free Samepage account or use an existing one.

2. Go to Samepage, create a new page and copy the URL.

The page will serve for saving backups.

3. In the administration interface, go to section Integration → Remote Storage.

4. Enter your Samepage email address and password.

Only the specified user will have access to the Samepage page with backups.

Figure 1 Samepage.io integration settings

5. Test the connection.

6. If the connection is established successfully, go to Advanced Options → Backup and

Recovery.

7. Click the Edit button and paste the Samepage URL of the backup page to the URL field.

8. Test the URL by clicking on the Backup on Remote Storage button.

9. Select Enable automatic backup to remote storage.

10. In the Start at field, specify the time at which backups should be performed.

11. In the Period field, specify how often backups should be performed.

12. Next to Content, click Edit and select content types for backup.

By default, Kerio Operator backs up only a system configuration. Full backup (all items

are selected) increases size of the backup.

13. Save the settings.

http://samepage.io/
http://samepage.io/
http://community.samepage.io/threads/working-with-pages.234/
http://community.samepage.io/threads/working-with-pages.234/
http://community.samepage.io/threads/working-with-pages.234/
http://community.samepage.io/threads/working-with-pages.234/
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Figure 2 Samepage.io integration settings

Saving backups to an FTP server

Kerio Operator can automatically backup to an FTP server.

1. In the administration interface, go to section Integration → Remote Storage.

2. Type a hostname of your FTP server

3. Type a username and password if it is necessary.

4. Click Apply.

5. Go to Advanced Options → Backup and Recovery.

6. Change Type to FTP.

7. Test the settings by clicking on the Backup on Remote Storage button.

8. Select Enable automatic backup to remote storage.

9. In the Start at field, specify the time at which backups should be performed.

10. In the Period field, specify how often backups should be performed.

11. Next to Content, click Edit and select content types for backup.

By default, Kerio Operator backs up only a system configuration. Full backup (all items

are selected) increases size of the backup.

12. Save the settings.



Configuring backups in Kerio Operator

142

Saving a single backup file

1. Go to Advanced Options → Backup and Recovery.

2. In the Backup section, click Download Backup File.

3. Select a backup content.

By default, Kerio Operator creates a full backup.

4. Click Create Backup for Download.

5. Click Download and save the file.

Recovering data from a backup

1. Download a backup file from Samepage or an FTP server or locally saved backup from

your computer.

2. In the administration interface, go to Advanced Options → Backup and Recovery.

3. Click Upload Backup File.

4. Select the file and upload the backup to Kerio Operator.

5. When the Recovery dialog box appears, select the configuration and data for recovery.

6. Click Recovery.

7. A warning about restart appears, click OK.

After the restart, the backup recovery is complete.

After restoring from a backup, you may need to restart your browser in order to log

back into the administration interface.
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Outgoing calls constraints

Why disable outgoing calls

For security reasons.

If attackers obtain usernames and passwords of your users they can use your Kerio Operator

to call premium rate numbers. Thus you can lose a large amount of money.

Configure outgoing calls constraint to prevent these types of attacks.

Disabling outgoing calls

Restricting the length of individual outgoing calls

Maximum call duration can be done as follows:

1. Open Configuration → Security in the administration interface.

2. Set Maximum duration of each outgoing call. Recommended value is 2 hours.

Restricting the number and length of outgoing calls

You can limit outgoing calls by creating special rules in section Configuration → Security in

table Outgoing calls constraints:

The default rule limits all outgoing calls to 50 per hour and total call duration to 2 hours per

day.

Example

The manufacturer sells and has contacts in the North America and EU. They want to limit calls

to other countries.

1. In the administration interface, open Configuration → Security and click Add.

2. Type a rule name (e.g. Constraints for countries outside the Northern America

and EU).

3. In section Apply to these outgoing calls, select All except listed and click Add.

4. Add prefixes to North America and EU. International prefixes can be found, for example,

on Wikipedia.

http://en.wikipedia.org/wiki/List_of_country_calling_codes
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Each international call prefix must be preceded by your prefix for outgoing calls:

If prefix for outgoing calls is 9, type 9001 for Northern America, 9003 and 9004 for EU.

5. Define the conditions: Set Maximum calls count to 10 per hour and Maximum total calls

duration to 1 hour a day.

6. When the conditions are met, Kerio Operator can send a warning email or block all

outgoing calls.

We recommend to create:

• One soft rule with lower limits which will send warning messages via email.

• One other rule with higher limits which will block the PBX.

If the limits are reached and the PBX is blocked, nobody will be able to call to external

networks. You can unlock the PBX in section Configuration → Security. We recommend to

make a thorough analysis of your calls so that the PBX is not blocked by standard operations.

Besides these settings, you can configure similar rules for specific users or groups of users.

https://kb.kerio.com/article/disabling-outgoing-calls-to-certain-prefixes.html
https://kb.kerio.com/article/disabling-outgoing-calls-to-certain-prefixes.html
https://kb.kerio.com/article/disabling-outgoing-calls-to-certain-prefixes.html
https://kb.kerio.com/article/disabling-outgoing-calls-to-certain-prefixes.html
https://kb.kerio.com/article/disabling-outgoing-calls-to-certain-prefixes.html
https://kb.kerio.com/article/disabling-outgoing-calls-to-certain-prefixes.html
https://kb.kerio.com/article/disabling-outgoing-calls-to-certain-prefixes.html
https://kb.kerio.com/article/disabling-outgoing-calls-to-certain-prefixes.html
https://kb.kerio.com/article/disabling-outgoing-calls-to-certain-prefixes.html
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Configuring Built-in DHCP server in Kerio Operator

Why to use built-in DHCP server

New in Kerio Operator 2.1!

Kerio Operator includes a built-in DHCP server. There are deployment scenarios in which it is

useful to have a separate DHCP server for VoIP devices:

• In larger networks, you may need a LAN segment dedicated to voice traffic.

• In smaller networks, the router/firewall sometimes does not support the DHCP option

66 for automatic provisioning of phones.

DHCP server is disabled in the default mode so that it does not collide with your

existing DHCP server.

Configuring DHCP server

The new DHCP server has to have static IP address:

1. In Kerio Operator administration interface, go to the Network section.

2. Select a network interface and click Edit.

3. In the Interface Properties dialog, switch configuration to Use the following configura-

tion and type a new static IP address, mask and gateway.

4. Check Enable DHCP server.

5. Click OK to save the settings.

Kerio Operator will derive the configuration of the DHCP server from the values you set for

the interface’s IP address, network mask, and gateway. The DHCP server sends option 66 to

Kerio Operator’s own address with every address lease.

http://en.wikipedia.org/wiki/Dynamic_Host_Configuration_Protocol
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Example — LAN segment is dedicated to voice traffic

In our example, you have LAN and you need to add an other network interface as a special

telephony segment (see scheme DHCP is running on the particular segment).

Figure 1 DHCP is running in the particular segment —scheme

You need to configure two interfaces in Kerio Operator administration interface:

1. Go to section Configuration → Network → General.

2. Configure interfaces as displayed in the screenshot DHCP is running on the particular

segment.

Figure 2 DHCP is running in the particular segment
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Configuring NAT

Kerio Operator is behind NAT and phones are in the Internet

1. In the administration interface, open section Configuration → Network → General.

2. In the NAT support section, enable NAT by checking the option.

3. Enter the public address which should be used in SIP protocol messages.

4. For phones in the same private network as Kerio Operator, create an appropriate IP

address group in section Configuration → Definitions → IP Address Groups with all

addresses on which phones communicate in your private network. Thus, the PBX will

communicate with phones within the network directly.

5. (Optional) You can also limit the RTP port range. Bear in mind that each call requires 4

ports for communication.

6. Also, map the following ports from firewall to Kerio Operator:

• TCP+UDP/5060

• TCP/5061

It is usually necessary to map a port range for RTP (according to the specified interval).

Figure 1 Kerio Operator is behind NAT and hardware phones are in the Internet
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Kerio Operator is in the company network and hardware phones are be-

hind NAT

Firstly, configure NAT for Kerio Operator.

The scenario in figure requires only one minor configuration in the PBX settings:

1. In the administration interface, open the Configuration → Extensions section.

2. Select the extension of the user whose phone is in a private network.

3. In the Edit extension dialog, go to tab Advanced.

4. Check the Extension is behind NAT option.

Figure 2 Kerio Operator is in the company network and hardware phones are behind NAT

Kerio Operator is behind NAT and hardware phones are in the Internet

Firstly, configure NAT for Kerio Operator.

If the telephone is in the Internet (not behind NAT), Kerio Operator does not require special

configuration.

Phones which are in the Internet cannot be managed in section Phone Provisioning.

http://kb.kerio.com/article/configuring-automatic-phone-provisioning.html
http://kb.kerio.com/article/configuring-automatic-phone-provisioning.html
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Disabling outgoing calls to certain prefixes

Why to disable outgoing calls to certain prefixes

If anybody elicits usernames and passwords from your users (using phone, email or virus),

your outgoing calls constraints will make them useless to the attacker.

The attacker obtains username and password and establishes phone services with premium

numbers (usually in a country where such fraudulent behavior is not illegal). They then use

your PBX to call these premium rate numbers. Thus you can lose a large amount of money.

For cases of a break-in, it is critical to have calls to external networks well configured. Disable

calls to countries users never call. Since you may have employees with different needs, you

can create call permission groups to external networks and assign them to users according to

their needs.

Each group of constraints can be used easily according to the following method:

• everything is allowed except for the explicitly disallowed

• everything is disabled except for the explicitly allowed

How to disable outgoing calls

Groups whose calls are blocked are defined in section Definitions → Call Permission Groups.

1. Click Add.

2. In the Add Call Permission Group dialog, enter the name and description for the group.

3. Click Add. Add a specific number or prefix and decide whether such number can be used

or will be blocked.

If you wish to limit calls to external network, beer in mind that external

numbers in these definitions must include the prefix for outbound calls.

4. Click OK to save the settings or repeat step 3 for additional numbers.

The rules are applied in order, one by one, so bear this in mind when creating

permission groups.
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Figure 1 Call permission groups settings

Assign the created call permission groups to individual users (Configuration → Users).
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Example

The Live And Let Laugh Inc headquarters is located in HPR, i.e. Happy People Republic.

Employees in this office can make calls within the country and also to the neighboring BSL

(Bliss Seekers Land). Calls to other countries (especially calls out of Emotion Union) would

be costly and there is actually no reason to make such calls. Thomas Punchline (company

network administrator) can change the settings easily to block such calls.

• the prefix for calling to external network must be a part of the string (in our case, it

is 9)

• all international prefixes (00) are forbidden

• enable the prefix for Bliss Seekers Land — 0052 (including the prefix for calling

external network, it makes 90052)

Apply settings as described below:

1. In section Configuration → Definitions → Call Permission Groups, click Add.

2. Enter the name for the group (for example, International calls disabled) and a

description.

3. In dialog Add Call Permission Group, click Add and enter the prefix for international

calls 00 together with your prefix for calls to external networks which is 9. The result is

900.

4. Set the rule to Deny.

5. To allow calls to the Bliss Seekers Land, it is necessary to add another rule. This rule

allows calls to prefix 0052.

6. Figure 1 shows the example of the final configuration.
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Fax support in Kerio Operator

Using fax in Kerio Operator

Kerio Operator supports:

• T.38 protocol

• Fax-to-email

• PDF-to-fax

T.38 support

T.38 is a protocol for realtime transmission of fax over IP.

Kerio Operator uses T.38 by default. Ask your provider whether they support this protocol. If

not, read section My provider does not support T.38.

Connecting a fax machine to Kerio Operator

1. Connect your fax machine to an Analog Telephone Adapter device (ATA — for example,

Cisco SPA 112).

2. Assign one of Kerio Operator extensions to the ATA device.

Fax machine is connected to the network. You can send and receive faxes.

Configuring an ATA device

You can use various ATA devices. Each device has different settings. The following must be

configured:

1. enable T.38

2. set fax passthru to ReInvite

Phone provisioning in Kerio Operator sets these variables automatically.

http://kb.kerio.com/product/kerio-operator/server-configuration-kerio-operator/configuring-automatic-phone-provisioning-820.html
http://kb.kerio.com/product/kerio-operator/server-configuration-kerio-operator/configuring-automatic-phone-provisioning-820.html
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Receiving faxes to a user’s email address

You can enable fax-to-email service for any extension. Kerio Operator then sends all incoming

faxes to the user’s email address as PDF and TIFF attachments.

In the administration interface, define SMTP relay in section Advanced Options →

General so that your Kerio Operator can send emails.

In the administration interface:

• go to Users and enter an email address for each user.

• go to Extensions and enable option Forward incoming faxes to user’s address for

the particular user’s extension.

Figure 1 Forward incoming faxes to user’s address

Configuring fax detection (CNG signal)

A CNG signal is the fax machine sound you may hear when there is a fax machine connected

to the other end of line. Kerio Operator can detect the signal and start receiving faxes

automatically.

1. In the administration interface, go to Extensions.

2. Double-click a selected extension.

3. On tab Advanced, select:

• Dial extension, wait for answer, detect CNG — PBX dials an extension, waits for

an answer and then starts detecting the CNG signal. User has to answer a call first

in order to receive faxes. When a fax tone is detected, the call will be taken over

by Kerio Operator.

• Answer, detect CNG, dial extension — PBX answers a call first, then detects the

CNG signal and immediately dials an extension. If users don’t answer the phone,
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a fax mail is received and users have a missed call on their phone display. This

option is good for occasional fax transmissions.

• Answer, detect CNG, wait 3.5 seconds, dial extension — Extension is dialed after

a 3.5 seconds delay which is used to detect faxes. There will not be any missed

calls shown on the phone’s display. Regular calls will be automatically answered

and will be followed by a 3.5 second delay of silence. This option is good for more

frequent fax usage.

• Answer, detect CNG, wait 3.5 seconds (ringing tone), dial extension — the PBX

will generate a ringing tone instead of waiting in silence. This option is also good

for more frequent fax usage and may be less confusing to human callers.

4. Save the settings.

Receiving all faxes to a specific email address

Kerio Operator can send all incoming faxes to a single email address.

1. Go to PBX Services.

2. Open Receive fax messages.

3. Type email address in the Send received faxes by email to field.

Figure 2 Setting a service for sending incoming fax to email address

Kerio Operator will send all incoming fax messages to the specified email address.

My provider does not support T.38

Fax support without T.38 is not reliable. Using codecs G.711 A-law/U-law instead of

T.38 is a workaround.
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If your SIP provider does not support T.38, you have to solve these issues:

• Enable codecs G.711 A-law/U-law for the transmission. High compression codecs

would distort signal.

• Reduce the speed on your fax machines (if supported).

Enabling G.711 A-law/U-law codecs for the interface

1. Login to the administration interface.

2. Go to Configuration → Call Routing.

3. Click the provider’s interface.

Figure 3 Choosing the provider’s interface

4. Click the Codecs tab.

5. Move G.711 A-law and G.711 U-law to the Selected codecs table.

6. Move G.711 A-law and G.711 U-law codecs up in the table.

Moving G.711 A-law/U-law codecs up in the table can cause bandwidth

consumption.

7. Click OK.

Fax messaging now uses codecs G.711 A-law/U-law.
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Figure 4 Moving codecs up

Sending PDF to fax

This feature is described in a special article: Sending PDF to fax in Kerio Operator client.

http://kb.kerio.com/article/sending-pdf-to-fax-in-kerio-myphone-1230.html
http://kb.kerio.com/article/sending-pdf-to-fax-in-kerio-myphone-1230.html
http://kb.kerio.com/article/sending-pdf-to-fax-in-kerio-myphone-1230.html
http://kb.kerio.com/article/sending-pdf-to-fax-in-kerio-myphone-1230.html
http://kb.kerio.com/article/sending-pdf-to-fax-in-kerio-myphone-1230.html
http://kb.kerio.com/article/sending-pdf-to-fax-in-kerio-myphone-1230.html
http://kb.kerio.com/article/sending-pdf-to-fax-in-kerio-myphone-1230.html
http://kb.kerio.com/article/sending-pdf-to-fax-in-kerio-myphone-1230.html
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Distinctive ringing support

Distinctive ringing overview

New in Kerio Operator 2.1!

Kerio Operator supports setting different ring tones for diferrent types of calls (external calls,

internal calls or rining groups).

Supported strings

The types of calls are represented by alert-info strings. Kerio Operator supports the following

strings:

• operator-external (calls from an interface)

• operator-queue (calls from a call queue)

• operator-group (calls to a ringing group)

Configuring a telephone (example: snom 360)

1. Go to web administration of your telephone.

2. Go to Setup → Preferences

3. Find the alert-info settings.

4. Set different ringers for different alert-info strings (see screenshot 1).

5. Save the settings.

For testing purposes: Try to make a call from an external telephone number, from an internal

extension and to rining group.
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Figure 1 Customising Alert-Info strings
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Legal Notice

Trademarks and registered trademarks

Active Directory is registered trademark of Microsoft Corporation.

Cisco and Linksys are registered trademarks of Cisco Systems, Inc.

Digium is registered trademark of Digium, Inc.

snom is registered trademark of snom technology AG.

Wireshark is registered trademark of Wireshark Foundation.

SJphone is registered trademark of SJ Labs, Inc.

X-Lite is a software phone developed by CounterPath Corporation with registered trademark

of CounterPath.

Firefox is registered trademark of Mozilla Foundation.

Internet Explorer is registered trademark of Microsoft Corporation.

Safari is registered trademark of Apple Inc.

Used open source software

This product contains the following open-source libraries:

Appliance OS Sources

Kerio Operator devices are based on open software from various resources. For detailed

information on conditions of each particular software used in the product, refer to

acknowledgements.

To download the source package, go to http://download.kerio.com/archive/.

asterisk

Asterisk - An open source telephony toolkit.

Copyright  1999 - 2012 Digium, Inc. and others.

Heimdal Kerberos

Heimdal is an implementation of Kerberos 5, largely written in Sweden. It is freely

available under a three clause BSD style license (but note that the tar balls include

parts of Eric Young’s libdes, which has a different license). Other free implementations

include the one from MIT, and Shishi. Also Microsoft Windows and Sun’s Java come with

implementations of Kerberos.

Copyright 1997-2000 Kungliga Tekniska Hogskolan (Royal Institute of Technology,

Stockholm, Sweden). All rights reserved.

Copyright 1995-1997 Eric Young. All rights reserved.

/Acknowledgements.txt
http://download.kerio.com/archive/
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Copyright 1990 by the Massachusetts Institute of Technology

Copyright 1988, 1990, 1993 The Regents of the University of California. All rights

reserved.

Copyright 1992 Simmule Turner and Rich Salz. All rights reserved.

Kerio Asterisk Module

The Kerio Asterisk Module extends the functionality of the Asterisk PBX to match Kerio

Operator needs. It is distributed and licensed under GNU General Public License version

2. The complete source code is available at:

http://download.kerio.com/archive/

Copyright  2010 Kerio Technologies s.r.o

 Copyright 2000-2006 T.I.P Group S.A. and the IBPP Team (www.ibpp.org).

libcurl

Libcurl is a free and easy-to-use client-side URL transfer library. This library supports the

following protocols: FTP, FTPS, HTTP, HTTPS, GOPHER, TELNET, DICT, FILE and LDAP.

Copyright 1996-2008, Daniel Stenberg.

libiconv

Libiconv converts from one character encoding to another through Unicode conversion.

Copyright 1999-2003 Free Software Foundation, Inc.

Author: Bruno Haible

Homepage: http://www.gnu.org/software/libiconv/

The libiconv library is distributed and licensed under GNU Lesser General Public License

version 3.

Kerio Operator includes a customized version of this library. Complete source codes of

the customized version of libiconv library are available at:

http://download.kerio.com/archive/

libmbfl

libmbfl is a streamable multibyte character code filter and converter library. The libmbfl

library is distributed under LGPL license version 2.

Copyright 1998-2002 HappySize, Inc. All rights reserved.

The library is available for download at:

http://download.kerio.com/archive/

libxml2

XML parser and toolkit.

Copyright 1998-2003 Daniel Veillard. All Rights Reserved.

Copyright 2000 Bjorn Reese and Daniel Veillard.

Copyright 2000 Gary Pennington and Daniel Veillard

Copyright 1998 Bjorn Reese and Daniel Stenberg.

http://download.kerio.com/archive/
http://www.gnu.org/software/libiconv/
http://download.kerio.com/archive/
http://download.kerio.com/archive/
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OpenLDAP

Freely distributable LDAP (Lightweight Directory Access Protocol) implementation.

Copyright  1998-2007 The OpenLDAP Foundation

Copyright 1999, Juan C. Gomez, All rights reserved

Copyright 2001 Computing Research Labs, New Mexico State University

Portions Copyright1999, 2000 Novell, Inc. All Rights Reserved

Portions Copyright PADL Software Pty Ltd. 1999

Portions Copyright 1990, 1991, 1993, 1994, 1995, 1996 Regents of the University of

Michigan

Portions Copyright The Internet Society (1997)

Portions Copyright 1998-2003 Kurt D. Zeilenga

Portions Copyright 1998 A. Hartgers

Portions Copyright 1999 Lars Uffmann

Portions Copyright 2003 IBM Corporation

Portions Copyright 2004 Hewlett-Packard Company

Portions Copyright 2004 Howard Chu, Symas Corp.

OpenSSL

An implementation of Secure Sockets Layer (SSL v2/v3) and Transport Layer Security (TLS

v1) protocol.

This product includes software developed by the OpenSSL Project for use in the OpenSSL

Toolkit (http://www.openssl.org/).

This product includes cryptographic software written by Eric Young.

This product includes cryptographic software written by Tim Hudson.

PHP

PHP is a widely-used scripting language that is especially suited for Web development

and can be embedded into HTML.

Copyright 1999-2006 The PHP Group. All rights reserved.

This product includes PHP software, freely available from http://www.php.net/software/

ScoopyNG

This product includes software developed by Tobias Klein.

Copyright 2008, Tobias Klein. All rights reserved.

tftpd

TFTP daemon. TFTP is a simple protocol used for file transmission.

Copyright 1983 Regents of the University of California. All rights reserved.

WAVPlayerProject

WAV player.

Denis Kolyako May 28, 2007, see http://etcs.ru/copyright/

zlib

General-purpose library for data compressing and decompressing.

Copyright 1995-2005 Jean-Loup Gailly and Mark Adler.

http://www.openssl.org/
http://www.php.net/software/
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